Jira Core 7.12.x upgrade notes

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問

Here are some important notes on upgrading to Jira Core 7.12. For details of the new features and improvements in this release, see the Jira Core 7.12 release notes

アップグレードノート

Jira 管理者

Apache Tomcat のアップグレード

Apache Tomcat を 8.5.32 バージョンにアップグレードしました。これにより、server.xml ファイルへの変更が必要です。

問題点

Apache Tomcat サーバーは特殊文字が含まれるリクエストをフィルタリングするため、このようなリクエストが失敗します。これは、Tomcat がほとんどのブラウザとは異なるエンコーディングおよび URI 標準を採用しているためです (詳細はこちら)。この問題は、多くの特殊文字 ([]<> など) を使用する JQL 検索でもっともよく見られますが、Jira の他のページにも影響を与える可能性があります。 

手順

この問題を解決するには、server.xml ファイルを編集し、リクエスト内の特殊文字を Tomcat が許可するようにするプロパティを追加します。

  1. <Jira-installation-directory>/conf に移動し、server.xml ファイルを編集します。
  2. アプリケーションで使用中のすべてのコネクタを見つけます。ファイルで Connector を検索するか、以下の例をご覧ください。
  3. server.xml の connector プロパティに relaxedPathChars="[]|" relaxedQueryChars="[]|{}^&#x5c;&#x60;&quot;&lt;&gt;" を追加します。例:

    <Connector port="8080" relaxedPathChars="[]|" relaxedQueryChars="[]|{}^&#x5c;&#x60;&quot;&lt;&gt;" maxThreads="150" minSpareThreads="25" connectionTimeout="20000" enableLookups="false" maxHttpHeaderSize="8192" protocol="HTTP/1.1" useBodyEncodingForURI="true" redirectPort="8443" acceptCount="100" disableUploadTimeout="true" bindOnInit="false"/>
  4. Jira を再起動します。

PostgreSQL 9.3 のサポート終了について

Jira 7.12 では PostgreSQL 9.3 の使用が非推奨となりました。Jira 8.0 では PostgreSQL 9.3 のサポートを完全に終了します。詳細については、「サポート終了のお知らせ」を参照してください。

監査ログの新イベント (フィルタとダッシュボード)

リリース ノートに記載されているように、ユーザーは自身が編集権限を持つフィルタおよびダッシュボードを共有できるようになりました。監査ログの新しいイベントを介してすべての変更を確認できます。詳細については、「監査ログの表示」を参照してください。

プラグイン開発者

プラグインに関連する重要な変更については、「Jira 7.12 への準備」を参照してください。

アップグレード手順

注:まずテスト環境をアップグレードします。本番環境にロールする前に、テスト環境でアップグレードをテストしてください。

すでに Jira のいずれかのバージョンをご利用中の場合は、以下の説明に従って最新バージョンにアップグレードします。

  1. アップグレードする前に、インストール先のディレクトリ、ホームディレクトリ、およびデータベースをバックアップされることを強くお勧めします。
  2. リリース ノートとアップグレード ガイド (ご利用のバージョンから最新バージョンまでのすべてのリリース分) を読みます。
  3. 最新バージョンの Jira をダウンロードします。
  4. アップグレードガイド」の説明に従ってください。

以前のバージョンからのアップグレード方法

  • 7.0 以降
    アップグレード マトリクスをご確認ください。複数のバージョンをまたいでアップグレードする際に注意すべき既知の問題が掲載されています。
  • 7.0 より前
    移行ハブを参照してください。Jira 7.0 リリースでは大幅な変更が行われています。まず Jira 7.0 にアップグレードしてから、それ以降のバージョンにアップグレードする必要があります。
最終更新日: 2018 年 9 月 15 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.