Confluence セキュリティ勧告 - 2009-08-20

Confluence のセキュリティの概要とアドバイザリ

このページの内容

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問

In this advisory:

プロファイル画像処理における権限エスカレーションの脆弱性

重大度

Atlassian rates this vulnerability as high, according to the scale published in Confluence Security. The scale allows us to rank a vulnerability as critical, high, moderate or low.

Risk Assessment

権限エスカレーションの脆弱性を特定しました。この脆弱性によって、プロファイル画像を指定する際に、Confluence の管理領域と機能に対するアクセス権を攻撃者に提供する可能性があります。状況によっては、攻撃者が使用を許可されていない Confluence 管理機能にアクセスできるようになる可能性があります。

Risk Mitigation

この問題に対応するには、Confluence 3.0.1 にできるだけ早くアップグレードする必要があります。または、次の「修正セクション」内のパッチの手順に従ってください。必要なパッチを適用するかアップグレードを実行するまで、必要に応じて wiki へのパブリック サインアップを無効にできます。さらに厳しく制御するために、信頼されたグループへのアクセスを制限したり、システムにパッチが適用されるかアップグレードされるまで、匿名アクセスを無効にしたりできます。

Vulnerability

Confluence 3.0.0 までのすべてのバージョンにおけるプロファイル画像の処理機能が、この問題の影響を受けます。ただし、Confluence 3.0.0 以降で利用できる フォーム トークン処理メカニズムが用意されているため、Confluence のこれらのバージョンの管理領域はこの脆弱性によって侵害されません。

修正

This issue has been fixed in Confluence 3.0.1 (see the release notes), which you can download from the download centre.

Confluence 3.0.1 へのアップグレードを希望せず、Confluence 2.10.x を実行している場合は、Jira サイトで提供されているパッチをダウンロードしてインストールできます。パッチを適用する前に、最新リリース (2.10.3) にアップグレードすることを強くお勧めします。詳細については「CONF-16141」をご参照ください。

この脆弱性を報告してくださった エモリー大学Elliot Kendall 様に感謝いたします。当社では脆弱性の報告を完全にサポートしており、問題の特定と解決に対する皆様の協力に感謝しています。

さまざまなページとブログ投稿の機能における XSS 脆弱性

重大度

Atlassian rates these vulnerabilities as high, according to the scale published in Confluence Security. The scale allows us to rank a vulnerability as critical, high, moderate or low.

Risk Assessment

さまざまな Confluence ページ/ブログの機能における多数の XSS 脆弱性を特定して修正しました。これらは、公共の環境の Confluence インスタンスに影響を与える可能性があります。

XSS 脆弱性によって、悪意のあるユーザー (攻撃者) が独自の JavaScript を Confluence ページに埋め込めるようになります。

  • 攻撃者は、この脆弱性を利用して他のユーザーのセッション クッキーやその他の資格情報を盗み、その資格情報を攻撃者自身の Web サーバーに送り返す可能性があります。
  • 攻撃者のテキストとスクリプトが、Confluence ページを表示している他のユーザーに表示される可能性があります。これにより、貴社の評判が損なわれる可能性があります。

You can read more about XSS attacks at cgisecurity, CERT and other places on the web.

Risk Mitigation

これらの脆弱性を解決するため、Confluence インストールをパッチまたはアップグレードすることをお勧めします。以下の「修正」セクションを参照してください。

あるいは、すぐにアップグレードする立場にないが必要だと判断した場合は、必要なパッチまたはアップグレードを適用するまでは、wiki へのパブリック アクセス (匿名アクセスパブリック サインアップなど) を無効にする必要があると判断できます。さらに厳しく制御するために、信頼されたグループへのアクセスを制限できます。

Vulnerability

攻撃者は、以下の表に示す Confluence アクションに独自の JavaScript を注入できます。各アクションは、ユーザーが Confluence で特定の機能 (リンクやボタンのクリックなど) を実行したときに呼び出されます。アクションは、ブラウザーのアドレス バーに URL を入力するだけでも呼び出せます。不正な JavaScript は、ユーザーが URL を呼び出すときに実行されます。

For more details please refer to the related JIRA issue, also shown in the table below.

Confluence アクション

影響する Confluence バージョン

可用性を修正

More Details

ユーザー名リンクのクリック

3.0.0

3.0.0 と 3.0.1

CONF-15970

スペース間のページの移動

2.8 ~ 2.10.3(これらを含む)

2.10.x と 3.0.1

CONF-16019*
CONF-16135*

WebDAV 設定ページへのコンテンツの入力

3.0.0
WebDAV プラグインのバージョン 2.0 を持つ 2.10.x

2.10.x、3.0.0、および 3.0.1

CONF-16136

PDF エクスポート スタイルシートへのコンテンツの入力

3.0.0

3.0.0 と 3.0.1

CONF-16209

*これらの課題の 1 つにパッチを適用すると、もう一方の課題が修正されます。

修正

これらの問題は Confluence 3.0.1 で修正されています。ダウンロード センターからダウンロードできる「リリース ノート」をご参照ください。

Confluence 3.0.1 にアップグレードしない場合は、Jira サイトで提供されているパッチ ファイルをダウンロードしてインストールすることで、既存のインストールにパッチを適用できます。WebDAV プラグインの脆弱性については、プラグインのバージョンのアップグレードが含まれます。パッチを適用する前に、実行している Confluence のメジャー バージョンの最新リリースにアップグレードすることを強くお勧めします。たとえば、Confluence 2.10.1 を実行している場合は、バージョン 2.10.3 にアップグレードしてからパッチを適用する必要があります。詳細については、上記の脆弱性の表に示されている特定の Jira 課題をご参照ください。

最終更新日 2013 年 9 月 13 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.