Confluence セキュリティ勧告 - 2019-12-18

Confluence のセキュリティの概要とアドバイザリ



アトラシアン コミュニティをご利用ください。


Confluence Server and Data Center - Atlassian Companion Man-in-the-Middle - CVE-2019-15006

要約CVE-2019-15006 - Atlassian Companion Man-in-the-Middle

 10:00 AM PST (Pacific Time, -7 hours)

  • Confluence Server
  • Confluence Data Center

Affected Confluence Server Versions

  • Starting with 6.11.0
  • 6.11.x
  • 6.12.x
  • 6.13.x before 6.13.10 (the fixed version for 6.13.x)
  • 6.14.x
  • 6.15.x before 6.15.10 (the fixed version for 6.15.x)
  • 7.0.x before 7.0.5 (the fixed version for 7.0.x)
  • 7.1.x before 7.1.2 (the fixed version for 7.1.x)
  • 7.2.x before 7.2.0 (the fixed version for 7.2.x)
  • 6.11.0
  • 6.11.1
  • 6.11.2
  • 6.12.0
  • 6.12.1
  • 6.12.2
  • 6.12.3
  • 6.12.4
  • 6.13.0
  • 6.13.1
  • 6.13.2
  • 6.13.3
  • 6.13.4
  • 6.13.5
  • 6.13.6
  • 6.13.7
  • 6.13.8
  • 6.13.9
  • 6.14.0
  • 6.14.1
  • 6.14.2
  • 6.14.3
  • 6.15.1
  • 6.15.2
  • 6.15.3
  • 6.15.4
  • 6.15.5
  • 6.15.6
  • 6.15.7
  • 6.15.8
  • 6.15.9
  • 7.0.1
  • 7.0.2
  • 7.0.3
  • 7.0.4
  • 7.1.0
  • 7.1.1

EAP and beta versions:

  • 7.2.0-rc2
  • 7.2.0-rc1
  • 7.2.0-beta1
  • 7.1.0-rc3
  • 7.1.0-rc2
  • 7.1.0-rc1
  • 7.1.0-beta1
  • 7.0.1-rc1
  • 7.0.1-beta2
  • 7.0.1-beta1
  • 6.15.0-rc1
  • 6.15.0-beta2
  • 6.15.0-beta1
  • 6.14.0-rc1
  • 6.14.0-beta1
  • 6.13.0-rc1
  • 6.13.0-beta1
  • 6.12.0-rc1
  • 6.12.0-beta1
  • 6.11.0-rc1
  • 6.11.0-beta1

Fixed Confluence Server Versions

  • 7.2.0
  • 7.1.2
  • 7.0.5
  • 6.15.10
  • 6.13.10
CVE IDCVE-2019-15006


This advisory discloses a medium severity security vulnerability which was introduced in version 6.11.0 of Confluence Server and Confluence Data Center. Versions of Confluence Server and Confluence Data Center affected by this vulnerability:

  • from 6.11.0 before 6.13.10 (fixed in 6.13.10)
  • 6.14.0 から 6.15.10 の前まで(6.15.10 で修正)
  • from 7.0.1 before 7.0.5 (fixed in 7.0.5)
  • from 7.1.0 before 7.1.2 (fixed in 7.1.2)
  • from 7.2.0-beta1 before 7.2.0 (fixed in 7.2.0)

Atlassian Cloud instances have already been upgraded to a version of Confluence which does not have the issue described on this page.

Customers who have upgraded Confluence Server and Confluence Data Center to version 6.13.10, 6.15.10, 7.0.5, 7.1.2, 7.2.0 or higher are not affected.

Customers who are on any of the affected versions listed above, upgrade your Confluence Server and Confluence Data Center installations immediately to fix this vulnerability.

Atlassian Companion man-in-the-middle


Atlassian rates the severity level of this vulnerability as moderate, according to the scale published in our Atlassian severity levels. The scale allows us to rank the severity as critical, high, moderate or low.

これはアトラシアンの評価であり、お客様自身の IT 環境への適用性を評価する必要があります。


There was a man-in-the-middle (MITM) vulnerability present in the Confluence Previews plugin in Confluence Server and Confluence Data Center. This plugin was used to facilitate communication with the Atlassian Companion application. The Confluence Previews plugin in Confluence Server and Confluence Data Center communicated with the Companion application via the domain name, the DNS A record of which points at Additionally, a signed certificate for the domain was publicly distributed with the Companion application. An attacker in the position to control DNS resolution of their victim could carry out a man-in-the-middle (MITM) attack between Confluence Server (or Confluence Data Center) and the domain intended to be used with the Companion application. This certificate has been revoked, however, usage of the domain name was still present in Confluence Server and Confluence Data Center. An attacker could perform the described attack by denying their victim access to certificate revocation information, and carry out a man-in-the-middle (MITM) attack to observe files being edited using the Companion application and/or modify them, and access some limited user information.

Confluence Server と Confluence Data Center のバージョン 6.11.0 以降 6.13.10 の前まで (6.13.x の修正バージョン、6.12x と 6.11.x)、6.14.0 以降 6.15.10 の前まで (6.15.x の修正バージョン)、7.0.1 以降 7.0.5 の前まで (7.0.x の修正バージョン)、7.1.0 以降 7.1.2 の前まで (7.1.x の修正バージョン)、7.2.0 - ベータ 1 以降 7.2.0 の前まで (7.2.x の修正バージョン) はこの脆弱性の影響を受けます。この課題は CONFSERVER-59244 - 課題情報を取得中... ステータスで追跡できます。


We would like to acknowledge "SwiftOnSecurity" for reporting this vulnerability.


We have released the following versions of Confluence Server to address this issue:

We have released the following versions of Confluence Data Center to address this issue:


Atlassian recommends that you upgrade either to the latest Enterprise release version, which is 6.13.10, or to the latest version. For a full description of the latest version of Confluence Server and Confluence Data Center, see the Release Notes. You can download the latest Confluence Server and Data Center Enterprise Release from the download center.

Upgrade to a fixed version of Confluence Server and Confluence Data Center.

(1) 現行の Enterprise リリース バージョン (2017 年 12 月 18 日以降にリリースされた Enterprise バージョン) または旧バージョン (2018 年 12 月 2 日以前にリリース) をご利用の場合は、最新の Enterprise リリース バージョン (6.13.10) にアップグレードしてください。

現在のバージョン…then upgrade to this Enterprise release version:


6.13.10 (recommended)

(2) If you have a current feature version (a feature version released on 18 June 2019 or later), upgrade to the next bug-fix version of your current feature version.

現在のバージョン…then upgrade to this bug fix version:

(3) If you have an older version (a feature version released before 18 June 2019) but cannot upgrade to an Enterprise Release version, upgrade to any of these versions.

現在のバージョン…then upgrade to any of these versions:



Confluence サーバーまたは Data Center をすぐにアップグレードできない、または Confluence Cloud に移行中の場合は、一時的な回避策として、Confluence プレビュー プラグインを手動でアップデートするか、Confluence プレビュー プラグイン内で Companion アプリの統合を無効にします。 

If you have Confluence 6.13 and later, manually upgrade the plugin

To upgrade the Confluence Previews plugin:

  1. Download the appropriate version of the Confluence Previews plugin for your version of Confluence from the table below.
  2. > [アプリを管理] の順に移動します。
  3. Choose Upload and follow the prompts to manually install the plugin.

詳細については「Marketplace アプリのインストール: ファイル アップロードによるインストール」をご確認ください。

Confluence バージョン

Confluence Previews plugin version with fix

Confluence 7.1.xconfluence-previews-9.1.5
Confluence 7.0.xconfluence-previews-9.0.4
Confluence 6.15.7 - 6.15.10confluence-previews-8.2.2
Confluence 6.15.0 - 6.15.6confluence-previews-8.1.5
Confluence 6.14.xconfluence-previews-8.0.7
Confluence 6.13.x (Enterprise release)confluence-previews-7.0.19

To confirm the plugin was updated correctly go to  > Manage apps and search for Confluence Previews plugin. Expand the listing, and check the version number matches the plugin version listed above for your version of Confluence. 

If you have Confluence 6.11 or 6.12, disable the Companion App integration

This will disable the "Edit with" functionality. To disable the Atlassian Companion App integration:

  1. > [アプリを管理] の順に移動します。
  2. Choose System Apps from the drop-down menu then search for Confluence Previews.
  3. Click to expand the list of plugin modules.
  4. Disable the following plugin modules. Not all of these modules may be present in your version of the plugin.
    • Edit With plugin for the Media Viewer (companion-plugin)
    • 埋め込み「Edit With (編集)」ボタン (埋め込み編集)
    • ADCClient AMD Wrapper (companion-client-wrapper)
    • Edit With button (companion-plugin-button)
    • Templates for Edit With feature (companion-plugin-templates)

To confirm the Companion App integration was disabled successfully, insert a file into a page. View the page and click the file thumbnail to view the file in the preview. The “Edit with” menu should not appear. 


このセキュリティ アドバイザリーのメールが届いておらず、今後受信を希望する場合は、 にアクセスしてアラート メールに登録してください。

この勧告に関してご質問や懸念がある場合は、 でサポート リクエストを作成してください。


セキュリティ バグの修正ポリシー

アトラシアンの新しいポリシーに記載のとおり、重大なセキュリティ バグ修正は、 に応じてバックポートされます。新しいポリシーの対象バージョンについては、バイナリ パッチではなく新しいメンテナンス リリースが提供されます。

バイナリ パッチのリリースは終了しています。 

セキュリティの問題の重大度レベルアトラシアンのセキュリティ勧告には重大度レベルと CVE ID が含まれます。重大度レベルは、それぞれの脆弱性についてアトラシアンが独自に計算した CVSS スコアに基づきます。CVSS は業界標準の脆弱性メトリックです。CVSS の詳細を でご確認ください。
サポート終了ポリシー サポート終了ポリシーは、製品によって異なります。詳細は、アトラシアンの「製品終了ポリシー」を参照してください。 

最終更新日: 2020 年 1 月 8 日


Powered by Confluence and Scroll Viewport.