Confluence セキュリティ勧告 - 2008-05-21

Confluence のセキュリティの概要とアドバイザリ

このページの内容

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問

In this advisory:

ユーザーは権限に関係なく、添付ファイルを任意のページに移動できます

重大度

Atlassian rates this vulnerability as high, according to the scale published in Confluence Security. The scale allows us to rank a vulnerability as critical, high, moderate or low.

Risk Assessment

スペースで「ページの作成」権限を持つユーザーが、移動先スペースにおけるユーザーの権限に関わりなく、そのスペース内のページから Confluence サイトの他のページに添付ファイルを移動できるセキュリティ上の欠陥を特定して修正しました。

Confluence 1.0 ~ 2.8.0 のすべてのバージョンには脆弱性があります。

Risk Mitigation

このセキュリティ上の欠陥は、Confluence サイトのいずれかのスペースで、「ページを作成」権限をすでに持っているユーザーにのみ追加の権限を付与するものです。ほとんどのインストールでは、これは信頼されたユーザーのグループとなります。

Confluence インスタンスで、信頼性の低いユーザー グループが 1 つのスペースでページを作成して編集することを許可しながら、他のスペースへのアクセスを制限している場合は、必要なパッチまたはアップグレードを適用するまでは、wiki へのパブリック アクセス (匿名アクセスパブリック サインアップなど) を無効にする必要があると判断できます。さらに厳しく制御するために、信頼できるグループへのアクセスのみに制限できます。

Vulnerability

Confluence スペースで「ページを作成」権限を持つユーザーは、そのスペース内のページから Confluence サイトの他のページに添付ファイルを移動できます。移動先スペースのユーザー権限は関係ありません。

注: ユーザーがスペースを作成する権限を持っている場合は、パーソナル スペースを含めて、自分が作成するすべてのスペースにおいても「ページを作成」権限も持ちます。そのようなユーザーは、自分が作成したスペースに添付ファイルをアップロードして、その添付ファイルを Confluence サイトの任意のページに移動できます。

修正

This issue has been fixed in Confluence 2.8.1 (see the release notes), which you can download from the download centre.

または、Confluence 2.7.x または Confluence 2.8.0 のパッチをダウンロードしてインストールできます。Jira サイトから課題 CONF-11452 をご確認ください。

この問題をアトラシアンに報告してくださった CustomWareStafford Vaughan に感謝します。私たちは脆弱性の報告を完全にサポートしており、問題の特定と解決に対する皆様の協力に感謝しています。

ページ情報ビューの XSS 脆弱性

重大度

Atlassian rates this vulnerability as high, according to the scale published in Confluence Security. The scale allows us to rank a vulnerability as critical, high, moderate or low.

Risk Assessment

公共の環境内の Confluence インスタンスに影響する可能性のあるセキュリティ上の欠陥を、特定して修正しました。この欠陥は Confluence アクションの XSS (Cross-site Scripting) の脆弱性であり、悪意のあるユーザー (ハッカー) が独自の JavaScript を Confluence ページに埋め込める可能性があります。

  • ハッカーは、この欠陥を利用して他のユーザーのセッション cookie やその他の資格情報を盗み、その資格情報を攻撃者自身の Web サーバーに送り返す可能性があります。
  • The hacker's text and script might be displayed to other people viewing the Confluence page. This is potentially damaging to your company's reputation.

You can read more about XSS attacks at cgisecurity, CERT and other places on the web.

The following Confluence versions are vulnerable: All versions from 1.3 to 2.8.0 inclusive.

Risk Mitigation

必要と判断した場合は、この機能を無効にすることで、ページ情報ビューの参照元を非表示にできます。

Vulnerability

ハッカーは wiki ページの「情報」ビューに表示される参照元 URL に、独自の JavaScript を挿入できます。不正な JavaScript は、ユーザーが「情報」ビューを開いた時に実行されます。

修正

This issue has been fixed in Confluence 2.8.1 (see the release notes), which you can download from the download centre.

または、Confluence 2.7.x または Confluence 2.8.0 のパッチをダウンロードしてインストールできます。Jira サイトから課題 CONF-11524 をご確認ください。

Last modified on Mar 22, 2019

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.