Confluence セキュリティ勧告 - 2008-10-14

Confluence のセキュリティの概要とアドバイザリ

このページの内容

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問

In this advisory:

Confluence におけるパラメータ インジェクションの脆弱性

重大度

アトラシアンは、この脆弱性を重大と評価しています。これは Confluence セキュリティで公開されている尺度に従って決定されます。スケールによって、脆弱性を重大、高度、中度、低度として評価できます。

Risk Assessment

悪意のあるユーザー (ハッカー) が URL 文字列にパラメーターを追加して Confluence リクエストに独自の値を注入できる欠陥を、特定して修正しました。この欠陥によって、ハッカーは Confluence のセキュリティ チェックを迂回して、実行が許可されていないアクションを実行できるようになります。

Risk Mitigation

To address the issue, you should upgrade Confluence as soon as possible or follow the patch instructions below. If you judge it necessary, you can block all untrusted IP addresses from accessing Confluence.

Vulnerability

ハッカーは Confluence サーバーで、Confluence のセキュリティ チェックをバイパスし、特定のアクションを実施するパラメータを含む URL 文字列を設計することができます。この原因は、Confluence がサーバーでアクションを適用する前に、ユーザー入力を適切にサニタイズしていないことです。

攻撃者がこの問題を悪用すると、データにアクセスしたりデータを変更したりして、Confluence アプリケーションを侵害できる可能性があります。

Confluence 1.3 ~ 2.9.1 のすべてのバージョンには脆弱性があります。

修正

This issue has been fixed in Confluence 2.9.2 (see the release notes), which you can download from the download centre.

Confluence 2.9.2 へのアップグレードを希望しない場合は、影響を受ける任意のバージョンの Confluence で動作するパッチを利用できます。Jira サイトのパッチをダウンロードしてインストールできます。詳細については「CONF-13092」をご参照ください。

XSS Vulnerability in Various Confluence Actions and Plugins

重大度

Atlassian rates these vulnerabilities as high, according to the scale published in Confluence Security. The scale allows us to rank a vulnerability as critical, high, moderate or low.

Risk Assessment

We have identified and fixed a number of security flaws which may affect Confluence instances in a public environment. The flaws are all XSS (cross-site scripting) vulnerabilities in various Confluence actions. Each vulnerability potentially allows a malicious user (hacker) to embed their own JavaScript into a Confluence page.

  • ハッカーはこの欠陥を利用して他のユーザーのセッション クッキーやその他の資格情報を盗み、その資格情報をハッカー自身の Web サーバーに送り返す可能性があります。
  • The hacker's text and script might be displayed to other people viewing the Confluence page. This is potentially damaging to your company's reputation.

You can read more about XSS attacks at cgisecurity, CERT and other places on the web.

Risk Mitigation

必要に応じて、パブリック アクセスを無効にできます (例: 必要なパッチまたはアップグレードを適用するまでの、wiki への匿名アクセスパブリック サインアップ)。さらに厳しく制御するために、信頼されたグループへのアクセスを制限できます。

Vulnerability

ハッカーは、以下の表に示す Confluence アクションに独自の JavaScript を注入できます。各アクションは、ユーザーが Confluence で特定の機能 (リンクやボタンのクリックなど) を実行したときに呼び出されます。アクションは、ブラウザーのアドレス バーに URL を入力するだけでも呼び出せます。不正な JavaScript は、ユーザーが URL を呼び出すときに実行されます。

For more details please refer to the related JIRA issue, also shown in the table below.

Confluence アクション

影響する Confluence バージョン

More Details

報告者
(アトラシアンでない場合)

Pagetree プラグイン (Confluence に含まれている) を介して子を表示する

2.8.0 〜 2.9.1(これらを含む)

CONF-13043

Thomas Jaehnel

ソーシャル ブックマーク プラグイン (Confluence に含まれている) でブックマークを更新する

2.6.0 〜 2.9.1(これらを含む)

CONF-13041

Thomas Jaehnel

RSS フィードを作成

2.0 ~ 2.9.1(これらを含む)

CONF-13042

Thomas Jaehnel

検索マクロを使用した検索

All versions from 1.0 to 2.9.1 inclusive

CONF-13040

Thomas Jaehnel

検索

All versions from 1.0 to 2.9.1 inclusive

CONF-12944

 

修正

これらの問題は Confluence 2.9.2 で修正されています。ダウンロード センターからダウンロードできる「リリース ノート」をご参照ください。

Confluence 2.9.2 にアップグレードしない場合は、Jira サイトで提供されているパッチをダウンロードしてインストールできます。詳細については、上記の脆弱性の表に示されている特定の Jira 課題をご参照ください。

上記の XSS 脆弱性の大半を報告してくださった OPTIMAbitThomas Jaehnel 様に感謝いたします。当社では脆弱性の報告を完全にサポートしており、問題の特定と解決に対する皆様の協力に感謝しています。

Privilege Escalation Vulnerability in Confluence Watches

重大度

Atlassian rates this vulnerability as high, according to the scale published in Confluence Security. The scale allows us to rank a vulnerability as critical, high, moderate or low.

Risk Assessment

権限のないユーザーが Confluence ページを閲覧する権限を持っていなくてもウォッチしているページのリストにこのページを追加できる欠陥を、特定して修正しました。状況によっては、権限のないユーザーが閲覧を許可されていない情報にアクセスできる場合があります。

Risk Mitigation

この欠陥によって、権限のないユーザーがページを更新できず、ユーザーには閲覧権限のない情報に対するアクセス権が付与される可能性があります。

Vulnerability

権限のないユーザーが HTTP リクエストを操作できるため、このユーザーが閲覧権限を持たないページにウォッチを追加できます。このページはウォッチされたページのユーザーのリストに表示されて、ページ タイトルと対応するスペース名が表示されます。このようにして、ユーザーは Confluence の権限チェックを迂回して、表示を許可されていない情報にアクセスできるようになります。

Confluence 1.0 ~ 2.9.1 のすべてのバージョンには脆弱性があります。

修正

This issue has been fixed in Confluence 2.9.2 (see the release notes), which you can download from the download centre.

Confluence 2.9.2 にアップグレードしたくない場合、JIRA サイトで提供されているパッチをダウンロードしてインストールすることができます。詳細については、CONF-13039 を参照してください。

上記の脆弱性を報告してくださった OPTIMAbitThomas Jaehnel 様に感謝いたします。当社では脆弱性の報告を完全にサポートしており、問題の特定と解決に対する皆様の協力に感謝しています。

Confluence のお気に入りにおける権限エスカレーションの脆弱性

重大度

Atlassian は、この脆弱性を中規模と評価しています。これはConfluence セキュリティで公開されているスケールに従って決定されます。スケールによって、脆弱性を重大、高度、中規模、低度として評価することができます。

Risk Assessment

権限のないユーザーが Confluence ページを閲覧する権限を持っていなくてもお気に入りのリストに Confluence ページを追加できる欠陥を、特定して修正しました。状況によっては、権限のないユーザーが閲覧を許可されていない情報にアクセスできる場合があります。

Risk Mitigation

この欠陥によって、権限のないユーザーがページを更新できず、ユーザーには閲覧権限のない情報に対するごく限られたアクセス権のみが付与されます。

Vulnerability

権限のないユーザーが HTTP リクエストを操作して、このユーザーが閲覧権限を持たないページを「お気に入り」としてマークできます。これによって、このページはこのユーザーの複数のお気に入りに追加されます。このユーザーはこのページのタイトルやコンテンツを表示できませんが、お気に入りの数が増えていることはわかります。

Confluence 1.0 ~ 2.9.1 のすべてのバージョンには脆弱性があります。

修正

This issue has been fixed in Confluence 2.9.2 (see the release notes), which you can download from the download centre.

Confluence 2.9.2 にアップグレードしたくない場合、JIRA サイトで提供されているパッチをダウンロードしてインストールすることができます。詳細については、CONF-13044 を参照してください。

上記の脆弱性を報告してくださった OPTIMAbitThomas Jaehnel 様に感謝いたします。当社では脆弱性の報告を完全にサポートしており、問題の特定と解決に対する皆様の協力に感謝しています。

最終更新日 2013 年 9 月 13 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.