Confluence セキュリティ勧告 - 2008-12-03

Confluence のセキュリティの概要とアドバイザリ

このページの内容

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問

In this advisory:

さまざまな Confluence アクションの XSS 脆弱性

重大度

Atlassian rates these vulnerabilities as high, according to the scale published in Confluence Security. The scale allows us to rank a vulnerability as critical, high, moderate or low.

Risk Assessment

We have identified and fixed a number of security flaws which may affect Confluence instances in a public environment. The flaws are all XSS (cross-site scripting) vulnerabilities in various Confluence actions. Each vulnerability potentially allows a malicious user (hacker) to embed their own JavaScript into a Confluence page.

  • ハッカーはこの欠陥を利用して他のユーザーのセッション クッキーやその他の資格情報を盗み、その資格情報をハッカー自身の Web サーバーに送り返す可能性があります。
  • The hacker's text and script might be displayed to other people viewing the Confluence page. This is potentially damaging to your company's reputation.

You can read more about XSS attacks at cgisecurity, CERT and other places on the web.

Risk Mitigation

必要に応じて、パブリック アクセスを無効にできます (例: 必要なパッチまたはアップグレードを適用するまでの、wiki への匿名アクセスパブリック サインアップ)。さらに厳しく制御するために、信頼されたグループへのアクセスを制限できます。

Vulnerability

ハッカーは独自の JavaScript をさまざまな Confluence URL に挿入できます。影響を受ける機能領域については、以下の表をご参照ください。ユーザーが Confluence で特定の機能 (リンクやボタンのクリックなど) を実行したときに、URL が呼び出されることがあります。URL は、ブラウザーのアドレス バーに入力するだけでも呼び出せます。このような URL に不正な JavaScript が挿入された場合は、ユーザーが URL を呼び出すと JavaScript が実行されます。

For more details please refer to the related JIRA issue, also shown in the table below.

影響を受ける Confluence 機能

影響する Confluence バージョン

可用性を修正

More Details

報告者
(アトラシアンでない場合)

エラー メッセージの処理 (Confluence で使用されている DWR コード ライブラリの脆弱性)

2.7.3 〜 2.9.2(これらを含む)

2.9.2 と 2.10

CONF-11808

Bjoern Froebe

添付ファイル マクロ。

2.8 ~ 2.9.2(これらを含む)

2.8.2、2.9.2、2.10**

CONF-13713

 

添付ファイルのアップロード。

2.6 ~ 2.9.2(これらを含む)

2.8.2、2.9.2、2.10

CONF-13717

 

画像をサムネイルとして挿入する。

2.8 ~ 2.9.2(これらを含む)

2.8.2、2.9.2、2.10

CONF-13625

 

Confluence 500 のエラー ページにリストされたイベントのログを記録する。

2.9 ~ 2.9.2(これらを含む)

2.10 のみ

CONF-13584

 

Wiki マークアップ リンクのレンダリング。

2.7 ~ 2.9.2(これらを含む)

2.7.x、2.8.x、2.9.x、2.10

CONF-13451

 

*CONF-13717 のパッチは CONF-13736 のバグにも対応しています。
**この問題を修正するには、添付ファイル プラグインを最新バージョンにアップグレードしてください。このプラグインは、Confluence プラグイン リポジトリを介して Confluence 2.8.2、2.9.2、2.10 で利用できます。

修正

これらの問題は、ダウンロード センターからダウンロードできる Confluence 2.10 で修正されました (リリース ノート参照)。

Confluence 2.10 へのアップグレードを希望しない場合は、Jira サイトで提供されているパッチをダウンロードしてインストールできます。実行している Confluence のメジャー バージョンの最新リリースへアップグレードした後 (たとえば、Confluence 2.8 を実行している場合は、バージョン 2.8.2 にアップグレードする必要があります)、パッチを適用する必要があります。詳細については、上記の脆弱性の表に示されている特定の Jira 課題をご参照ください。

課題の 1 つは、Confluence 2.10 にアップグレードすることによってのみ修正できることにご注意ください。詳しくは上の表をご確認ください。

上記の XSS 脆弱性の 1 つを報告してくださった Bjoern Froebe 様に感謝いたします。当社では脆弱性の報告を完全にサポートしており、問題の特定と解決に対する皆様の協力に感謝しています。

ユーザーは編集した URL を指定してすべての添付ファイルのリストを表示できます

重大度

アトラシアンは、この脆弱性を中程度と評価しています。これは、Confluence セキュリティで公開されている尺度に従って決定されます。スケールによって、脆弱性を重大、高度、中度、低度として評価できます。

Risk Assessment

スペースレベルまたはページレベルの権限に関係なく、Confluence インスタンスのすべてのページにあるすべての添付ファイルのリストをユーザーが表示できるセキュリティ上の欠陥を、特定して修正しました。

ユーザーはファイルを開けませんが、ファイル名、ファイルが添付されているページ、作成者、添付ファイルの作成日と最終更新日など、さまざまなメタデータを表示できます。

Risk Mitigation

必要なパッチを適用するかアップグレードを実行するまで、必要に応じて wiki への匿名アクセスを無効にできます。

Vulnerability

ユーザーがスペースの添付ファイルを表示している際に URL からスペース キーを削除すると、すべてのスペースのすべての添付ファイルに関する完全なリストが表示されます。詳細については「CONF-13874」をご参照ください。

修正

これらの問題は、ダウンロード センターからダウンロードできる Confluence 2.10 で修正されました (リリース ノート参照)。

Confluence 2.10 にアップグレードしない場合は、Jira 課題 CONF-13874 で提供されているパッチをダウンロードしてインストールできます。実行している Confluence をメジャー バージョンの最新のポイント リリースにアップグレードした後 (たとえば、Confluence 2.8 を実行している場合は、バージョン 2.8.2 にアップグレードする必要があります)、パッチを適用します。

上記の脆弱性を報告してくださった Matthew Goonan 様に感謝いたします。当社では脆弱性の報告を完全にサポートしており、問題の特定と解決に対する皆様の協力に感謝しています。

最終更新日 2014 年 7 月 2 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.