Crowd 2.5 Upgrade Notes

This document contains notes on upgrading an existing Crowd installation to Crowd 2.5 or later. You can see the features of Crowd 2.5 in the Crowd 2.5 Release Notes.

このページの内容:

アップグレード ノート

Please read the following sections and take action where the note applies to your Crowd installation, before upgrading to the new release of Crowd.

Refer to the Crowd 2.4 Upgrade Notes

If you have not yet upgraded to Crowd 2.4, please read the Crowd 2.4 upgrade notes before upgrading to Crowd 2.5.

Removal of Deprecated Functionality — Roles

Roles, deprecated since Crowd 2.0, have now been removed.

Spring Security upgraded to version 3

Atlassian Crowd Spring Security Integration now uses Spring Security version 3. Applications that integrate with Crowd will need to upgrade their use of Spring or continue to use the client libraries from Crowd 2.4.

Advance Notice of End of Support

Acegi Security

Acegi Security has been obsoleted by Spring Security and will no longer be supported in future releases of Crowd. We recommend upgrading your application to use the current version of Spring Security.

Apache DS 1.0

Apache DS 1.5 includes a number of important fixes over 1.0. Apache DS 1.0 will no longer be supported in future releases of Crowd and we recommend upgrading to Apache DS 1.5.

アップグレード手順

To upgrade to Crowd 2.5 from 2.4.x or earlier, please follow these upgrade instructions.

最終更新日: 2014 年 9 月 14 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.