Bamboo Security Advisory 2017-06-14

Incorrect permission check for deployment projects - CVE-2017-8907

Note: As of  September 2014 we are no longer issuing binary bug patches, instead we create new maintenance releases for the major versions we are backporting.

概要

CVE-2017-8907 - Incorrect permission check for deployment projects

Advisory Release Date

  10 AM PDT (Pacific Time, -7 hours)

製品 Bamboo

Affected Bamboo Versions

  • 5.0.0 <= version < 5.15.7
  • 6.0.0 <= version < 6.0.1

Fixed Bamboo Versions

  • for 5.15.x, Bamboo 5.15.7 has been released with a fix for this issue.
  • for 6.0.x, Bamboo 6.0.1 has been released with a fix for this issue.
CVE ID(s)
  • CVE-2017-8907

 

Summary of Vulnerability

This advisory discloses a critical severity security vulnerability which was introduced in version 5.0 of Bamboo. Versions of Bamboo starting with 5.0.0 before 5.15.7 (the fixed version for 5.15.x) and from 6.0.0 before 6.0.1 (the fixed version for 6.0.x) are affected by this vulnerability. 

 

Atlassian Cloud instances have already been upgraded to a version of Bamboo which does not have the issue described on this page.

Customers who have upgraded Bamboo to version 5.15.7 or 6.0.1 are not affected.

Customers who have downloaded and installed Bamboo >= 5.0.0 less than 5.15.7 (the fixed version for 5.15.x)

Customers who have downloaded and installed Bamboo >= 6.0.0 less than 6.0.1 (the fixed version for 6.0.x)

 

Please upgrade your Bamboo installations immediately to fix this vulnerability.



Incorrect permission check for deployment projects (CVE-2017-8907)

重大度

Atlassian rates the severity level of this vulnerability as critical, according to the scale published in our Atlassian severity levels. The scale allows us to rank the severity as critical, high, moderate or low.

This is our assessment and you should evaluate its applicability to your own IT environment.

 

説明

Bamboo did not correctly check if a user creating a deployment project had the edit permission and therefore the rights to do so. An attacker who can login to Bamboo as a user without the edit permission for deployment projects is able to use this vulnerability, provided there is an existing plan with a green build, to create a deployment project and execute arbitrary code on an available Bamboo Agent. By default a local agent is enabled this means that code execution can occur on the system hosting Bamboo as the user running Bamboo.

Versions of Bamboo starting with 5.0.0 before 5.15.7 (the fixed version for 5.15.x) and from 6.0.0 before 6.0.1 (the fixed version for 6.0.x) are affected by this vulnerability. This issue can be tracked here: https://jira.atlassian.com/browse/BAM-18405

 

Acknowledgements

Atlassian would like to credit Iordache Cosmin (@inhibitor181) for reporting this issue to us.

 

Fix

We have taken the following steps to address this issue:

  1. Released Bamboo version 6.0.1 that contains a fix for this issue.
  2. Released Bamboo version 5.15.7 that contains a fix for this issue.

What You Need to Do

Atlassian recommends that you upgrade to the latest version. For a full description of the latest version of Bamboo, see the release notes. You can download the latest version of Bamboo from the download centre.

Upgrade Bamboo to version 6.0.3 or higher (recommended)

If you are running Bamboo 5.15.x and cannot upgrade to 6.0.3 then upgrade to version 5.15.7.


Support

If you did not receive an email for this advisory and you wish to receive such emails in the future go to https://my.atlassian.com/email and subscribe to Alerts emails.

If you have questions or concerns regarding this advisory, please raise a support request at https://support.atlassian.com/.

参考

Security Bug fix Policy

As per our new policy critical security bug fixes will be back ported to major software versions for up to 12 months for JIRA and Confluence.  We will release new maintenance releases for the versions covered by the new policy instead of binary patches.

Binary patches will no longer be released. 

Severity Levels for security issues Atlassian security advisories include a severity level and a CVE identifier. This severity level is based on our self-calculated CVSS score for each specific vulnerability. CVSS is an industry standard vulnerability metric. You can also learn more about CVSS at FIRST.org.
End of Life Policy  Our end of life policy varies for different products. Please refer to our EOL Policy for details. 
Last modified on Jun 18, 2017

この翻訳に満足しましたか?

はい
いいえ
この記事についてのフィードバックを送信する

Not finding the help you need?

コミュニティへの質問

Powered by Confluence and Scroll Viewport.