Bamboo Security Advisory 2017-10-11

Bamboo - Remote Code Execution - CVE-2017-9514

Note: As of  September 2014 we are no longer issuing binary bug patches, instead we create new maintenance releases for the major versions we are backporting.

要約

CVE-2017-9514 - Remote Code Execution in Bamboo

Advisory Release Date

 10 AM PDT (Pacific Time, -7 hours)

製品 Bamboo

Affected Bamboo Versions

  • 6.0.0 <= version < 6.0.5 
  • 6.1.0 <= version < 6.1.4

Fixed Bamboo Versions

  • for 6.0.x, Bamboo 6.0.5 has been released with a fix for this issue.
  • for 6.1.x, Bamboo 6.1.4 has been released with a fix for this issue.
  • for 6.2.x, Bamboo 6.2.1 has been released with a fix for this issue.
CVE ID(s) CVE-2017-9514

 

Summary of Vulnerability

This advisory discloses a critical severity security vulnerability which was introduced in version 6.0.0 of Bamboo. Versions of Bamboo starting with 6.0.0 before 6.0.5 (the fixed version for 6.0.x ), 6.1.0 before 6.1.4 (the fixed version for 6.1.x) and 6.2.0 before 6.2.1 (the fixed version for 6.2.x) are affected by this vulnerability. 

Customers who have upgraded Bamboo to version 6.2.1 or 6.1.4 or 6.0.5 are not affected.

Customers who have downloaded and installed Bamboo >= 6.0.0 less than 6.0.5 (the fixed version for 6.0.x)

Customers who have downloaded and installed Bamboo >= 6.1.0 less than 6.1.4 (the fixed version for 6.1.x)

 

Please upgrade your Bamboo installations immediately to fix this vulnerability.

 

Remote code execution through YAML deserialization (CVE-2017-9514)

重大度

Atlassian rates the severity level of this vulnerability as critical, according to the scale published in our Atlassian severity levels. The scale allows us to rank the severity as critical, high, moderate or low.

This is our assessment and you should evaluate its applicability to your own IT environment.

 

説明

Bamboo had a REST endpoint that parsed a YAML file and did not sufficiently restrict which classes could be loaded An attacker who can log in to Bamboo as a user is able to exploit this vulnerability to execute Java code of their choice on systems that have a vulnerable version of Bamboo.

Versions of Bamboo starting with 6.0.0 before 6.0.5 (the fixed version for 6.0.x ), 6.1.0 before 6.1.4 (the fixed version for 6.1.x) and 6.2.0 before 6.2.1 (the fixed version for 6.2.x) are affected by this vulnerability. This issue can be tracked here:  BAM-18735 - Getting issue details... STATUS

Fix

We have taken the following steps to address this issue:

  1. Released Bamboo version 6.0.5 that contains a fix for this issue.
  2. Released Bamboo version 6.1.4 that contains a fix for this issue.
  3. Released Bamboo version 6.2.1 that contains a fix for this issue.

What You Need to Do

Atlassian recommends that you upgrade to the latest version. For a full description of the latest version of Bamboo, see the release notes. You can download the latest version of Bamboo from the download centre.

 

Upgrade Bamboo to version 6.2.1 or higher.

If you are running Bamboo 6.1.x and cannot upgrade to 6.2.1  then upgrade to version 6.1.4.

If you are running Bamboo 6.0.x and cannot upgrade to 6.1.4  then upgrade to version 6.0.5.

 

サポート

If you did not receive an email for this advisory and you wish to receive such emails in the future go to https://my.atlassian.com/email and subscribe to Alerts emails.

If you have questions or concerns regarding this advisory, please raise a support request at https://support.atlassian.com/.

参考

Security Bug fix Policy

As per our new policy critical security bug fixes will be back ported to major software versions for up to 12 months for JIRA and Confluence.  We will release new maintenance releases for the versions covered by the new policy instead of binary patches.

Binary patches will no longer be released. 

Severity Levels for security issues Atlassian security advisories include a severity level and a CVE identifier. This severity level is based on our self-calculated CVSS score for each specific vulnerability. CVSS is an industry standard vulnerability metric. You can also learn more about CVSS at FIRST.org.
サポート終了ポリシー  Our end of life policy varies for different products. Please refer to our EOL Policy for details. 
最終更新日: 2017 年 9 月 10 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.