Bamboo Security Advisory 2015-10-21

Bamboo - Deserialisation resulting in remote code execution

Note: As of September 2014, we are no longer issuing binary bug patches. Instead, we create new maintenance releases for the major versions we are backporting.

Date of Advisory:  (UTC)

CVE ID: CVE-2015-6576

Product: Bamboo

Affected Bamboo product versions: 

  • 2.2 <= version < 5.8.5
  • 5.9.0 <= バージョン < 5.9.7

Fixed Bamboo product versions:

  • for 5.8.x, Bamboo 5.8.5 has been released with a fix for this issue.
  • for 5.9.x, Bamboo 5.9.7 has been released with a fix for this issue.

脆弱性の概要

This advisory discloses a critical severity security vulnerability that was introduced in version 2.2 of BambooVersions of Bamboo starting with 2.2 before 5.8.5 (the fixed version for 5.8.x) and from 5.9.0 before 5.9.7 (the fixed version for 5.9.x) are vulnerable.

 

Atlassian Cloud instances have already been upgraded to a version of Bamboo which does not have the issue described on this page. 

Customers who have upgraded Bamboo to version 5.8.5 or version 5.9.7 are not affected

Customers who have downloaded and installed Bamboo >= 2.2 less than 5.8.5 (the fixed version for 5.8.x)

Please upgrade your Bamboo installations immediately to fix this vulnerability.

Customers who have downloaded and installed Bamboo >= 5.9.0 less than 5.9.7 (the fixed version for 5.9.x) 

Please upgrade your Bamboo installations immediately to fix this vulnerability.

Deserialisation Resulting in Remote Code Execution Vulnerability

重大度

Atlassian rates the severity level of this vulnerability as critical, according to the scale published in our Atlassian severity levels. The scale allows us to rank a severity as critical, high, moderate, or low.

This is an independent assessment and you should evaluate its applicability to your own IT environment.

説明

Bamboo had a resource that deserialised arbitrary user input without restriction. Attackers can use this vulnerability to execute Java code of their choice on systems that have a vulnerable version of Bamboo. To exploit this issue, attackers need to be able to access the Bamboo web interface.

All versions of Bamboo from 2.2 before 5.8.5 (the fixed version for 5.8.x) and from 5.9.0 before 5.9.7 (the fixed version for 5.9.x) are affected by this vulnerability. This issue can be tracked here:  BAM-16439 - Getting issue details... STATUS

謝辞

We would like to credit Matthias Kaiser of Code White for reporting this issue to us.

修正

We have taken the follow steps to address this issue:

  1. Released Bamboo version 5.9.7 that contains a fix for this issue.
  2. Released Bamboo version 5.8.5 that contains a fix for this issue.

必要なアクション

Upgrade (recommended)

The vulnerabilities and fix versions are described in the Description section above. Atlassian recommends that you upgrade to the latest version. 

 

Upgrade Bamboo to version 5.9.7 or higher.

If you are running Bamboo 5.8.x and cannot upgrade to bamboo 5.9.Xthen upgrade to version 5.8.5.


For a full description of the latest version of Bamboo, see the release notes. You can download the latest version of Bamboo from the download centre.

サポート

If you have questions or concerns regarding this advisory, please raise a support request at https://support.atlassian.com/ja/.

参考

セキュリティ バグの修正ポリシー

As per our new policy critical security bug fixes will be backported to major software versions for up to 12 months for JIRA and Confluence.  We will release new maintenance releases for the versions covered by the new policy instead of binary patches.

Binary patches will no longer be released. 

セキュリティの問題の重大度レベルアトラシアンのセキュリティ勧告には重大度レベルと CVE ID が含まれます。重大度レベルは、それぞれの脆弱性についてアトラシアンが独自に計算した CVSS スコアに基づきます。CVSS は業界標準の脆弱性メトリックです。CVSS の詳細を FIRST.org でご確認ください。
End-of-Life Policy Our end of life policy varies for different products. Please refer to our EoL Policy for details. 
最終更新日: 2015 年 10 月 23 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.