Cloud Migration Assistant for Confluence

robotsnoindex
descriptionConfluence Cloud Migration Assistant を使用して Confluence Server または Data Center から Confluence Cloud にデータを移行する方法についての詳細な手順です。

robotsnoindex
robotsnoindex

移行する前に、クラウド組織を確認してください

現在、移行操作に影響する可能性のある変更をロール アウト中です。admin.atlassian.com の組織で、[ユーザー] リストと [グループ] リストが [ディレクトリ] タブの下にある場合は、ユーザー管理エクスペリエンスが改善されています。つまり、複数サイトのユーザーとグループが組織にマージされています。グループと権限の移行方法の詳細をご確認ください。ご不明な点がありましたら、サポートまでご連絡ください。


テスト移行または UAT の場合、テスト クラウド サイトは、製品サイトもホストしている組織に含まれないものを使用することをお勧めします。製品サイトは、別の組織でホストするようにしてください。これは、関連するユーザーとグループのスムーズな移行を確保するためです。

Confluence Cloud Migration Assistant は、 Confluence Server または Data Center から Confluence Cloud への、コンテンツ、ユーザー、およびグループの簡単な移動を支援するアプリです。このアプリの構築と保守はアトラシアンが行なっています。アプリは無料でインストールおよび使用できます。

このアプリでは Cloud への移動対象を選択し、好きなタイミングで移行を開始できます。移行プロセスの間は、すべての項目の進捗状況を監視できます。

[Unable to render {include} The included page could not be found. ({include} をレンダリングできません。ページが見つかりませんでした)] を選択し、

Confluence Cloud Migration Assistant を使用するタイミング

  • Confluence Server または Data Center のユーザーやデータを既存の Confluence Cloud サイトに移動したいとき。

  • Confluence Server または Data Center から Confluence Cloud サイトに移行する前にアプリを評価したいとき。
  • Confluence Server または Data Center から Confluence Cloud へのテスト移行を行いたいとき。

  • アトラシアン株式会社からアプリの使用を推奨されたとき。

Confluence Cloud Migration Assistant を Jira 製品で使用することはできません。Jira のクラウド移行には、Jira Cloud Migration Assistant をダウンロードできます。 

はじめる前に

サーバーからクラウドへの移行ガイドを必ずご確認ください。このガイドでは、移行プロセスをステップバイステップで説明しており、問題点の特定に役立ちます。

テストまたは本番環境の移行を試行する前に、移行前のチェックリストで Confluence Cloud Migration Assistant 用のすべてのステップを完了していることをご確認ください。このチェックリストは、移行に向けて環境やデータを準備し、移行の失敗となる一般的な原因を回避するのにも役立ちます。

Confluence Cloud Migration Assistant アプリのインストール

Confluence Server サイトがバージョン 6.13 以降だった場合、 アプリは事前にインストールされているため、別途インストールする必要はありません。ただし、アプリの更新を求められることがあります。 


バージョン 5.10 ~ 6.12 でアプリをインストールするには、次の手順を実行します。

  1. Confluence Server で、[管理] メニュー > [アプリの管理] に移動します。
  2. [新しいアドオンを検索] を選択します。 
  3. Confluence Cloud Migration Assistant アプリを検索します。 
  4. [インストール] を選択したら完了です。

Atlassian Marketplace からインストールすることもできます。

インストールしたら、[Confluence 管理] に移動し、[Atlassian Cloud] カテゴリを探し、[移行アシスタント] を選択して、Migration Assistant にアクセスできます。

Confluence Server サイトがファイアウォールの内側にある場合、ドメイン atlassian.com へのアクセスを許可する必要があります。

移行アシスタントを使用してアプリを評価する

アプリの評価を実施すると、移行に必要なアプリを確認できます。 


「 Confluence Cloud Migration Assistant でアプリを評価および移行する」でこのプロセスの詳細な手順を確認できます。

クラウド サイトでのデータの競合の確認

サーバーとクラウド サイトでいくつかの手動チェックを実行することで、問題の発生や移行の失敗のリスクを軽減できます。

1. グループの競合の確認

クラウド サイト内に、サーバー サイトと同じ名前のグループが存在していないことを確認します (意図的に統合しようとしている場合を除く)。

クラウド サイト (Jira または Confluence) のグループと同じ名前を持つグループがサーバー サイト内に見つかった場合、ユーザーはサーバーのグループからクラウドのグループに統合されます。サーバー グループはクラウド グループの権限を継承します。これは、移行しようとしている Confluence グループと同じ名前の、Jira 製品アクセスを持つグループにも適用されます。これは、クラウド サイトではすべてのユーザーとグループが一元管理されるためです。

これを防ぐ場合、移行を実行する前に、サーバーとクラウドのすべてのグループの名前が一意であることを確認する必要があります。 


tip/resting Created with Sketch.

一部のグループは管理者アクセスを管理しているため、ブラックリストに登録されています。"site-admins"、"system-administrators"、"atlassian-addons"、"atlassian-addons-admin" グループは一切移行されません。これらのグループのユーザーは引き続き移行されます。ブラックリストの対象グループのいずれかにユーザーを含めたい場合、移行後に手動で追加する必要があります。

2. スペース キーの競合を確認する

移行前に、サーバーとクラウド サイトとの間に同じスペース キーを持つスペースがないことを確認します。

サーバー サイトのスペースがクラウド サイトのスペースと同じスペース キーを持っていた場合、移行は失敗します。これは、Confluence Cloud 内の各スペースに、一意のスペース キーが必要であるためです。競合が見つかった場合、次の操作を行うことができます。

Migration Assistant が競合を検出した場合、そのスペースは移行されません。

スペース キーの競合が過去のテスト移行によって発生している場合、移行前にクラウド サイトをリセットできます。

アプリを使用して移行をセットアップおよび開始する

アプリをインストールしたら、次の 5 つのステップで Server または Data Center から Cloud への移行をセットアップおよび実行します。

  1. クラウドに接続

  2. 移行対象を選択

  3. エラーの有無の確認

  4. 移行の確認

  5. 移行

以降のセクションでは各ステップを詳細に説明するとともに、発生する可能性がある一般的なエラーについて解説します。Migration Assistant の使用中に技術的な質問や問題があった場合、アトラシアンのサポート チームにお問い合わせください。

テスト移行を実行する

テストまたはステージング サイトへのテスト移行を行ってから最終移行を行うことを強く推奨します。移行テストのガイダンスをご参照ください。

1. 移行先の Confluence Cloud サイトに接続する

移行に名前を設定し、移行先のクラウド サイトを選択することを求められます。サーバー サイトと宛先のクラウド サイトの両方で管理者である必要があります。

すでにクラウド サイトに接続済みの場合、ドロップダウンでそれを確認できます。何も表示されない場合、新しいクラウド サイトに接続するか、新しいクラウド ライセンスにサインアップする必要があります。

準備が整ったら、サーバー サイトからクラウド サイトへのデータの転送をアトラシアンに許可するチェックボックスを選択します。このアクセスをアトラシアンに許可できない場合、Migration Assistant を使用した移行は行えず、代わりにスペース インポートを実行する必要があります。

Confluence Server サイトがファイアウォールの内側にある場合、ドメイン atlassian.com へのアクセスを許可する必要があります。また、他の Atlassian ドメインへのアクセスを許可する必要がある場合もあります。 

2. 移行対象を選択

すべてをまとめて移行することも、別の段階に分割することもできます。

選択肢は次のとおりです。

  • すべてまたは一部のユーザーおよびグループ

  • 移行する個別のスペース (およびそれらの添付ファイル)

Users and groups

ユーザーをすべて移行するか、一部を移行することを選択できます。

ユーザーを移行する場合、初回の実行時にすべてのユーザーがクラウド サイトに追加されます。以降のそれぞれの移行では、データがクラウド内に存在するユーザーにリンクされます。大規模なユーザーベースがある場合、弊社の推奨事項に従うことをおすすめします。

ユーザーを移行する場合、それらのユーザーはクラウドで該当するグループに追加されます。移行後にグループ権限を確認および承認する必要があります。グループ権限を承認すると、ユーザーには Confluence へのアクセス権が与えられ、ユーザーは請求対象に含められます。

ユーザーへの招待は送信されません。ユーザーを招待するには、移行後に管理スペースから招待を送信するか、自身でログインできるよう、当該ユーザーにリンクを送信します。

ユーザーとグループで [Only users related to the selected spaces (選択されたスペースに関係するユーザーのみ)] を選択しても、移行しているスペースに関連付けられている一部のユーザー データは引き続き移行されます。これは、メンション、コメント、およびページ履歴をアクティブな状態に保つためです。

必ず移行されるユーザー データには、次の情報が含まれます。

  • 氏名

  • ユーザー名 (移行後に破棄)

  • メール アドレス

移行するスペースに直接関連付けられているユーザーの情報のみが移行されます。これらのユーザーに製品アクセスが付与されたり、これらのユーザーがグループに追加されたりすることはありません。これらのユーザーはクラウド サイトのユーザー一覧に表示されます。

ユーザーをあとから移行することを選択した場合、それらのユーザーの製品およびグループ アクセスはあとで更新されます。

また、ユーザーとグループを移行しないことを選択し、クラウドに存在しないグループによって付与されたスペース権限がある場合、Confluence Cloud Migration Assistant は各スペース権限を移行しません。このシナリオを回避するには、移行の前にクラウドで当該グループを作成することをお勧めします。

ユーザーおよびグループの移行時には、次の点にもご注意ください。

  • ユーザーは、メール アドレスを使用して移行されます。以降の移行では、移行アシスタントはユーザーを再度移行するのではなく、メール アドレスを使用してユーザーをリンクさせます。「大量のユーザーを移行する際のヒント」をご確認ください。 

  • クラウドに移行する前に、すべてのユーザー アカウント (メール アドレス) を検証する必要があります。不明なユーザー アカウントを移行すると、クラウド サイトへの未承認のアクセスを許可することになる可能性があります。たとえば、“email@example.com” など、自分の組織が所有しないメール アドレスを使用するユーザーをサーバー インスタンスに含めると、“@example.com” を所有する何らかのユーザーをクラウドの自分のサイトに招き入れてしまう可能性があります。

  • Confluence Cloud はサブスクリプションベースで、ユーザー単位で請求が行われます。ユーザーの移行を予定している場合、使用可能なライセンス オプションを確認することをおすすめします。 

  • 外部のユーザー管理システムを使用している場合、移行前にローカル ユーザー ディレクトリと同期させることをおすすめします。これは、データを転送する前にユーザーやグループが最新であることを確認するためです。

  • サーバー サイトの無効ステータスのユーザーは、アクティブだが製品アクセスを持たないユーザーとして移行されます。つまり、請求時にはアクティブな Confluence ユーザーとしては計上されません。

  • クラウド サイトのグループと同じ名前を持つグループがサーバー サイト内に見つかった場合、そのユーザーはサーバーのグループからクラウドのグループに統合されます。

  • グローバル設定とグローバル サイト権限はこのツールでは移行されません。これらは移行後に手動で設定する必要があります。

  • 宛先クラウド サイトにすでにユーザーが存在していて、このアプリでユーザーを移行することを選択した場合、次のようになります。

    • ユーザーがクラウドで製品アクセスを持っているものの、サーバー サイトではステータスが無効となっている場合、そのユーザーは移行後も引き続きクラウドで製品アクセスを持ちます。

    • ユーザーがクラウドで製品アクセスを持っていないが、サーバー サイト内で有効化されている場合、移行プロセスを通じて製品アクセスが付与されます。

Confluence を Jira Service Management (旧 Jira Service Desk) のナレッジ ベースとして使用している場合、Jira Service Management ユーザーが Confluence ユーザーとともに移行される可能性があります。これは、Confluence の cwd_user テーブルに Jira Service Management ユーザーが含まれている場合に発生します。

スペース

スペースのすべてまたは一部を移行したい場合、オプションの [Select spaces] を選択します。移行するスペースを選択できます。スペースを移行しない場合、エラーの有無の確認に直接転送されます。

移行に含めたいスペースを選択します。一覧をフィルタリングすることも、特定のスペースを検索することもできます。すべてをまとめて移行したい場合、[Select all] をクリックします。宛先の Confluence Cloud サイトにすでに存在するスペース キーを持つスペースを移行することはできません。

スペースが MIGRATED ステータスの場合、対象のスペースは同じクラウド サイトにすでに移行されています。

スペースが QUEUED ステータスの場合、対象のスペースは実行待ちの移行にすでに追加されています。

多数のスペースや添付ファイルがある場合、または Data Center を使用している場合、小規模に分割した移行を行うことができます。Migration Assistant では、処理量が多い場合、読み込みやタスク処理の速度が低下する場合があります。

すべてのスペースを選択したら、[Add to migration] を選択します。 

3. エラーを確認する

このステップでは、Confluence Cloud Migration Assistant が移行を確認して一般的なエラーを見つけます。次の内容が確認されます。

  • Migration Assistant アプリが最新かどうか

  • ユーザーに有効で一意のメール アドレスが紐付けられているかどうか

  • 移行プロセスでのグループの統合

  • クラウド サイトにすでに存在するスペース

  • スペースが公開されオンラインで検索可能

このステップでは上述の問題のみが確認されます。移行プロセスではほかの問題が発生する可能性があります。

緑色のチェック マーク (tick) が表示された場合、チェックは完了しています。警告サイン (warning) が表示された場合、続行できますが、潜在的な問題がある点を確認しておく必要があります。

赤いエラー (error) が表示された場合、移行を実行する前にエラーを解決する必要があります。

[Continue and fix later] を選択した場合、移行を保存し、あとから再開してエラーを確認できます。

アプリのアップグレード

Migration Assistant が古くなっている可能性があります。このエラーが表示されたら、移行を実行する前にアプリを更新する必要があります。

ユーザーとグループのエラー

すべてのユーザーが有効で一意なメール アドレスを持っている必要があります。無効なメール アドレスや、複数のユーザーが同じメール アドレスを使用していることが検出された場合、エラーが表示されます。移行を実行する前にこれらのメール アドレスを修正する必要があります。

すべてのユーザーを移行することを選択した場合、クラウド サイトに同じ名前のグループがないかどうかが確認されます。同じ名前のグループが見つかった場合、サーバー グループのユーザーが同じ名前のクラウド グループに統合されます。この問題は修正せずに続行できますが、権限昇格が行われていないことを確認することをおすすめします。

tip/resting Created with Sketch.

一部のグループは管理者アクセスを管理しているため、ブラックリストに登録されています。"site-admins"、"system-administrators"、"atlassian-addons"、"atlassian-addons-admin" グループは一切移行されません。これらのグループのユーザーは引き続き移行されます。ブラックリストの対象グループのいずれかにユーザーを含めたい場合、移行後に手動で追加する必要があります。

スペースのエラー

スペースを移行する場合、スペース キーの競合が確認されます。エラーが発生した場合、次のいずれかを行えます。

移行を実行するには、スペース キーのすべての競合を解決する必要があります。

4. 移行の確認

これは移行のセットアップの最終ステップです。

すべてが適切に指定されており、移行を開始して問題ない場合は、[Run] をクリックします。後で移行を開始する場合、または修正が必要なエラーがある場合は、[Save] をクリックします。移行を実行するよう選択した場合も、移行計画は引き続き移行ダッシュボードに保存されます。ここで、すべての移行の進捗状況と詳細を確認できます。

5. 移行の管理

保存した移行は移行ダッシュボードに一覧表示されます。ここで、移行の詳細を表示したり、移行を実行したりすることができます。移行のステータスおよび実行中の移行の進捗状況の確認、実行中の移行の停止、新しい移行の作成なども可能です。

移行はいくつでも作成できます。現時点では、移行を編集または削除することはできません 。不要な移行を作成した場合、新しい移行を作成します。

ステータスの定義

SAVED 移行が保存済みで、移行を実行できる状態です。

RUNNING 移行が現在進行中です。

FINISHED  移行のすべてのタスクが完了しています。

STOPPED 移行が手動で停止されました。停止された移行を再開することはできません。移行が完全に停止するには、進行中のすべてのプロセスが終了する必要があります。一部のユーザー、グループ、およびスペースがすでに Confluence Cloud サイトに移行されている場合があります。

FAILED 移行を完了できませんでした。原因として、移行先のサイトにスペース キーがすでに存在していることや、移行で予期せぬエラーが発生した可能性が考えられます。一部のユーザー、グループ、およびスペースがすでに Confluence Cloud サイトに移行されている場合があります。

移行後

スペースの移行後、それらがスペース ディレクトリに表示されるには時間がかかる場合があります。ただし、直接リンク経由でアクセスすることはできます。

移行のタイプによっては、移行の完了後に実行が必要な操作があります。

Users and groups

ユーザーとグループが正しくセットアップされていることを確認するには、次の手順を実行します。

  • [インポートしたグループを確認] に移動して、グループのメンバーを確認し、権限を承認します (無料プランの場合、権限を変更することはできません。ユーザーとグループは元のサイトと同じ権限を保持します)。

  • 必要に応じて、汎用グループにユーザーを追加します。汎用グループの例: "site-admins"、"system-administrators"、"atlassian-addons"、"atlassian-addons-admin"。

  • 外部のユーザー管理システムを使用している場合は、ユーザーが正しく同期されていることを確認します。

  • 準備が整ったら、ユーザーを招待します。[管理] > [ユーザー] > [詳細の表示] の順に選択し、[招待の再送] を選択します。ユーザーが初めてログインすると、新しいパスワードを設定し、個人情報を追加するように求めるメッセージが表示される場合があります。

    ユーザー管理エクスペリエンスが改善された場合は、[管理] > [ディレクトリ] > [ユーザー] > [詳細の表示] の順に選択し、[招待を再送] を選択します。
  • 新しいクラウド ワークスペースに慣れるため、トレーニングの実施またはオンボーディング メールの送信をお勧めします。 

スペース

スペースの移行が正常に完了したことを確認するには、次の手順を実行します。

  • コンテンツとスペースを確認するか、ユーザーに自身のコンテンツを確認してもらいます。

  • Former User のインスタンスがあるかどうかを確認します。これは、コンテンツをユーザーに関連付けることができなかったことを意味します。

  • [設定] > [アプリケーション リンク] に移動して、他のアトラシアン製品をリンクします。

  • Jira マクロ リペアを使用して、Jira への任意のリンクを更新します。クラウド サイトで [設定] > [Jira Macro Repair] に移動し、ステップに従います。

移行後、https://confluence.example.com/x/PywS などの Confluence の短縮リンクが動作しない可能性があります。これを回避するには、移行前にこれらを内部リンク (Confluence サイト内のページではない場合は完全な URL) に置き換えます。

その後、必要なアプリをインストールして、ユーザーのオンボーディングを実行できます。

移行後アクションの詳細については、サーバーからクラウドへの移行ガイドをご確認ください。 

詳細情報とサポート

移行をサポートする多数のチャンネルをご用意しています。

 

最終更新日 2023 年 8 月 22 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.