Cannot run Stash 1.x on Tomcat 7/JDK 7

その他

このページの内容

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問

症状

The following appears in the atlassian-stash.log:

2012-08-07 11:53:55,212 ERROR [Spring executor 5]  c.a.plugin.osgi.factory.OsgiPlugin Unable to start the Spring context for plugin com.atlassian.crowd.embedded.admin
org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'handler' defined in URL [bundle://51.0:0/META-INF/spring/web-context.xml]: Initialization of bean failed; nested exception is java.lang.NoClassDefFoundError: javax/servlet/ServletContext
...
Caused by: java.lang.NoClassDefFoundError: javax/servlet/ServletContext
...
Caused by: java.lang.ClassNotFoundException: javax.servlet.ServletContext
...

原因

This ERROR happens because your are trying to deploy Stash 1.x on Apache Tomcat 7 which is not supported. Tomcat 7 is supported as of Stash 2.0.

回避策

Run Stash with the following custom flag: -Datlassian.org.osgi.framework.bootdelegation=javax.servlet,javax.servlet.,sun.,com.sun.,org.w3c.dom.

最終更新日 2016 年 3 月 30 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.