An error occured is shown every time users see a Pull Request

その他

このページの内容

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問


プラットフォームについて: Server、Data Center、および Cloud (状況に応じる) - この記事はアトラシアンのサーバーおよびデータセンター プラットフォーム向けに記載されていますが、Atlassian Cloud のお客様も記事の内容を利用できる可能性があります。この記事で説明されている手順の実施が役立つと考えられる場合、アトラシアン サポートにお問い合わせのうえ、この記事を紹介してください。

問題

Users are getting "An error occured" dialog every time they go to view a pull request.

After they click OK to the error box, the Pull Requests still displays as expected and can be approved and merged.

However the same error may be shown on merge even though the merge still works. This happens to all our users who are not project admins.

The log below is shown in the atlassian-stash.log every time the pop up is displayed on Stash UI:

2015-07-06 12:19:37,466 ERROR [http-nio-8443-exec-141] user @1HGFTZFx739x61282x5 adse4s IP "GET /rest/api/latest/projects/CB/repos/project/pull-requests/142/merge HTTP/1.1" s.b.s.SsccRepositoryMergeRequestCheck 
com.atlassian.stash.exception.AuthorisationException: You are not permitted to access this resource
	at com.atlassian.stash.internal.aop.ExceptionRewriteAdvice.afterThrowing(ExceptionRewriteAdvice.java:36) ~[stash-platform-3.10.2.jar:na]
	at se.bjurr.sscc.SsccRepositoryMergeRequestCheck.check(SsccRepositoryMergeRequestCheck.java:53) ~[na:na]
	at com.atlassian.stash.internal.pull.DefaultMergeRequestCheckService.doCheck(DefaultMergeRequestCheckService.java:73) [stash-service-impl-3.10.2.jar:na]
	... 
	... 

This only started occurring after upgrade from 3.10.0 to 3.10.2.

原因

The issue happens after the code goes through the code of the Simple Stash Commit Checker add-on (line at se.bjurr.sscc.SsccRepositoryMergeRequestCheck.check(SsccRepositoryMergeRequestCheck.java:53) ~[na:na])

回避策

Disable the Simple Stash Commit Checker add-on.

ソリューション

Please report this issue to the vendor's public issue tracker so they can fix it.

最終更新日: 2016 年 2 月 26 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.