CVE-2021-26077 - Broken authentication in Atlassian Connect Spring Boot (ACSB)

説明

Atlassian Connect Spring Boot is a Java Spring Boot package for building Atlassian Connect apps. Authentication between Atlassian products and the Atlassian Connect Spring Boot app occurs with a server-to-server JWT or a context JWT. Atlassian Connect Spring Boot version 2.1.4 introduced a regression to query string hash validation in lifecycle endpoints (such as installation), this regression permits an attacker to send authenticated re-installation event to an app using JWTs intended for other endpoints. This is fixed in version 2.1.5.
Note: This is the re-surfacing of CVE-2021-26074 - Broken authentication in Atlassian Connect Spring Boot (ACSB) in 2.1.4

影響バージョン

  • 1.1.0 - 2.1.2, 2.1.4

修正対象バージョン

  • 2.1.3, 2.1.5 and later

深刻度

This is an independent assessment and you should evaluate its applicability to your own IT environment.

CVSS v3 score: 9.1 => Critical severity

Exploitability Metrics

攻撃ベクトルネットワーク
攻撃の複雑さ
必要な権限
ユーザー相互作用なし



Scope Metric

範囲Changed



Impact Metrics

機密性
整合性
可用性


https://asecurityteam.bitbucket.io/cvss_v3/#CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L


最終更新日 2021 年 5 月 7 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.