Fisheye and Crucible Security Advisory 2018-03-28

Fisheye and Crucible - Argument injection through Mercurial repository URI handling on Windows - CVE-2018-5223

注: 2014 年 9 月現在、アトラシアンはバイナリ バグ パッチを発行しなくなりました。代わりに、バックポートしているメジャー バージョン用の新しいメンテナンス リリースを作成します。

要約

CVE-2018-5223 - Argument injection through Mercurial repository URI handling on Windows

勧告のリリース日

  10 AM PDT (Pacific Time, -7 hours)

製品Fisheye および Crucible

Affected Fisheye and Crucible Versions

  • バージョン < 4.4.6
  • 4.5.0
  • 4.5.1
  • 4.5.2

Fixed Fisheye and Crucible Versions

  • 4.4.6
  • 4.5.3
CVE IDCVE-2018-5223

脆弱性の概要

This advisory discloses a critical severity security vulnerability which affects Fisheye and Crucible. All versions of Fisheye and Crucible before 4.4.6 (the fixed version for 4.4.x) and from 4.5.0 before 4.5.3 (the fixed version for 4.5.x) running on the Windows operating system are affected by this vulnerability. 


Customers who have upgraded Fisheye and Crucible to version 4.4.6 or 4.5.3 are not affected.


Customers who do not run Fisheye or Crucible on the Windows operating system are not affected.

Customers who have downloaded and installed Fisheye and Crucible on Windows less than 4.4.6 (the fixed version for 4.4.x)

Customers who have downloaded and installed Fisheye and Crucible on Windows >= 4.5.0 less than 4.5.3 (the fixed version for 4.5.x)


Please upgrade your Fisheye and Crucible installations immediately to fix this vulnerability.


Argument injection through Mercurial repository URI handling on Windows (CVE-2018-5223)

重大度

アトラシアンはアトラシアンの重大度レベルで公開されているスケールに従って、この脆弱性の重大度レベルを重大として評価しています。このスケールによって、重大度を重大、高度、中度、低度として評価できます。

これはアトラシアンの評価であり、お客様自身の IT 環境への適用性を評価する必要があります。

説明

Fisheye and Crucible did not correctly check if a configured Mercurial repository URI contained values that the Windows operating system may consider argument parameters. An attacker who has permission to add a repository in Fisheye or Crucible can execute code of their choice on systems that run a vulnerable version of Fisheye or Crucible on the Windows operating system.


All versions of Fisheye and Crucible before 4.4.6 (the fixed version for 4.4.x) and from 4.5.0 before 4.5.3 (the fixed version for 4.5.x) are affected by this vulnerability.


This issue can be tracked for Fisheye at: https://jira.atlassian.com/browse/FE-7014 .

This issue can be tracked for Crucible at: https://jira.atlassian.com/browse/CRUC-8181.

謝辞

Atlassian would like to credit Zhang Tianqi @ Tophant for reporting this issue to us.

問題の軽減策

Atlassian recommends that you upgrade to the latest version. However, if you are unable to upgrade then you can apply the following mitigation.

This issue can be mitigated by uninstalling the Mercurial client executable from Fisheye and Crucible server.

修正

弊社ではこの問題に対応するために次の対応を行いました。

  1. Released Fisheye version 4.5.3 that contains a fix for this issue and can be downloaded from https://www.atlassian.com/software/fisheye/download.
  2. Released Crucible version 4.5.3 that contains a fix for this issue and can be downloaded from https://www.atlassian.com/software/crucible/download.
  3. Released Fisheye version 4.4.6 that contains a fix for this issue and can be downloaded from https://www.atlassian.com/software/fisheye/download-archives.
  4. Released Crucible version 4.4.6 that contains a fix for this issue and can be downloaded from https://www.atlassian.com/software/crucible/download-archives.

必要なアクション

Atlassian recommends that you upgrade to the latest version. For a full description of the latest version of Fisheye, see the release notes You can download the latest version of Fisheye from the download centre. For a full description of the latest version of Crucible, see the release notes You can download the latest version of Crucible from the download centre.


Upgrade Fisheye and Crucible to version 4.5.3 or higher.

If you are running Fisheye or Crucible 4.4.x and cannot upgrade to 4.5.3  then upgrade to version 4.4.6.

サポート

このセキュリティ アドバイザリーのメールが届いておらず、今後受信を希望する場合は、https://my.atlassian.com/email にアクセスしてアラート メールに登録してください。

If you have questions or concerns regarding this advisory, please raise a support request at https://support.atlassian.com/ja/.

参考

セキュリティ バグの修正ポリシー

As per our new policy critical security bug fixes will be back ported in accordance with https://www.atlassian.com/trust/security/bug-fix-policy.  We will release new maintenance releases for the versions covered by the new policy instead of binary patches.

バイナリ パッチのリリースは終了しています。 

セキュリティの問題の重大度レベルアトラシアンのセキュリティ勧告には重大度レベルと CVE ID が含まれます。重大度レベルは、それぞれの脆弱性についてアトラシアンが独自に計算した CVSS スコアに基づきます。CVSS は業界標準の脆弱性メトリックです。CVSS の詳細を FIRST.org でご確認ください。
サポート終了ポリシー サポート終了ポリシーは、製品によって異なります。詳細は、アトラシアンの「製品終了ポリシー」を参照してください。 
Last modified on Mar 23, 2018

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.