Fisheye and Crucible Security Advisory 2017-11-29

Fisheye and Crucible - Argument injection through filenames in a Mercurial repository - CVE-2017-14591

注: 2014 年 9 月現在、アトラシアンはバイナリ バグ パッチを発行しなくなりました。代わりに、バックポートしているメジャー バージョン用の新しいメンテナンス リリースを作成します。

要約

CVE-2017-14591 - Argument injection through Mercurial repository handling.

勧告のリリース日

 10 AM PDT (Pacific Time, -8 hours)

製品Fisheye および Crucible

影響を受けるバージョン

  • バージョン < 4.4.3 
  • 4.5.0

Fixed Versions

  • 4.4.3
  • 4.5.1
CVE IDCVE-2017-14591

 

脆弱性の概要

This advisory discloses a critical severity security vulnerability which affects Fisheye and Crucible. All versions of Fisheye and Crucible before 4.4.3 (the fixed version for 4.4.x) and from 4.5.0 before 4.5.1 (the fixed version for 4.5.x) are affected by this vulnerability. 

 

Customers who have upgraded their Fisheye and Crucible installations to version 4.4.3 or 4.5.1 are not affected.

Customers who have downloaded and installed Fisheye or Crucible less than version 4.4.3 (the fixed version for 4.4.x)

Customers who have downloaded and installed Fisheye or Crucible >= 4.5.0 less than version 4.5.1 (the fixed version for 4.5.x)

 

Please upgrade your Fisheye and Crucible installations immediately to fix this vulnerability.



Argument injection in Mercurial repository handling (CVE-2017-14591)

重大度

アトラシアンはアトラシアンの重大度レベルで公開されているスケールに従って、この脆弱性の重大度レベルを重大として評価しています。このスケールによって、重大度を重大、高度、中度、低度として評価できます。

これはアトラシアンの評価であり、お客様自身の IT 環境への適用性を評価する必要があります。

説明

Fisheye and Crucible did not check that the name of a file in a Mercurial repository contained argument parameters. An attacker who has permission to add a repository or commit to a mercurial repository tracked by Fisheye or Crucible, can execute code of their choice on systems that run a vulnerable version of Fisheye or Crucible.

All versions of Fisheye and Crucible before 4.4.3 (the fixed version for 4.4.x) and from 4.5.0 before 4.5.1 (the fixed version for 4.5.x) are affected by this vulnerability. 

This issue can be tracked for Fisheye at: https://jira.atlassian.com/browse/FE-6955 .

This issue can be tracked for Crucible at  https://jira.atlassian.com/browse/CRUC-8121 .

謝辞

Atlassian would like to credit Zhang Tianqi @ Tophant for reporting this issue to us.

問題の軽減策

Atlassian recommends that you upgrade to the latest version. However, if you are unable to upgrade then you can apply the following mitigation.

This issue can be mitigated by unconfiguring the Mercurial client executable path by following the instructions below 

  1. Go to the admin area of Fisheye or Crucible.
  2. Click Server (under 'Global Settings').
  3. Click Edit Details (under 'Hg Executable').
  4. Set the path to be empty.
  5. [更新] をクリックします。
  6. Restart your Fisheye server.

For more information on configuring the Mercurial executable path see https://confluence.atlassian.com/display/FISHEYE/Mercurial+Client.

修正

弊社ではこの問題に対応するために次の対応を行いました。

  1. Released Fisheye version 4.5.1 that contains a fix for this issue.
  2. Released Crucible version 4.5.1 that contains a fix for this issue.
  3. Released Fisheye version 4.4.3 that contains a fix for this issue.
  4. Released Crucible version 4.4.3 that contains a fix for this issue.

必要なアクション

Atlassian recommends that you upgrade to the latest version. For a full description of the latest version of Fisheye, see the release notes You can download the latest version of Fisheye from the download centre. For a full description of the latest version of Crucible, see the release notes You can download the latest version of Crucible from the download centre.

 

Upgrade Fisheye and Crucible to version 4.5.1 or higher.

If you are running Fisheye or Crucible 4.4.x and cannot upgrade to 4.5.1  then upgrade to version 4.4.3.


サポート

このセキュリティ アドバイザリーのメールが届いておらず、今後受信を希望する場合は、https://my.atlassian.com/email にアクセスしてアラート メールに登録してください。

If you have questions or concerns regarding this advisory, please raise a support request at https://support.atlassian.com/ja/.

参考

セキュリティ バグの修正ポリシー

Atlassian の新しいポリシーにあるように、重大なセキュリティ バグの修正は、Jira と Confluence のメジャー ソフトウェア バージョンで最大 12 か月さかのぼってバックポートされます。新しいポリシーに挙げるバージョンについては、バイナリ パッチではなく新しいメンテナンス リリースを提供します。

Binary patches will no longer be released. 

セキュリティの問題の重大度レベルアトラシアンのセキュリティ勧告には重大度レベルと CVE ID が含まれます。重大度レベルは、それぞれの脆弱性についてアトラシアンが独自に計算した CVSS スコアに基づきます。CVSS は業界標準の脆弱性メトリックです。CVSS の詳細を FIRST.org でご確認ください。
サポート終了ポリシー サポート終了ポリシーは、製品によって異なります。詳細は、アトラシアンの「製品終了ポリシー」を参照してください。 
最終更新日: 2017 年 12 月 4 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.