Upgrade to Confluence 5.8.x failed due to Unsupported major.minor version 52.0 (unable to load class com.atlassian.confluence.setup.ConfluenceConfigurationListener)

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問

プラットフォームについて: Server と Data Center のみ - この記事は、サーバーおよびデータセンター プラットフォームのアトラシアン製品にのみ適用されます。

問題

Upgrading to Confluence 5.8.x from 5.7.x or earlier fails. The following appears in the atlassian-confluence.log

java.lang.UnsupportedClassVersionError: 
com/atlassian/confluence/setup/ConfluenceConfigurationListener : 
Unsupported major.minor version 52.0 (unable to load class 
com.atlassian.confluence.setup.ConfluenceConfigurationListener)

診断

環境

  • Existing Confluence installation (5.7.x or earlier).
  • Upgrading to Confluence 5.8.x or later.
  • Java version 1.7.x.

原因

The upgrade is blocked due to a JDK mismatch. Confluence 5.8.x requires Java 1.8.x, and will not function using Java 1.7.x.

See our guide to Supported Platforms for more info.

ソリューション

Our guide to Installing Java for Confluence will help you download and install Java 1.8.x for use with Confluence 5.8.x.

tip/resting Created with Sketch.

There's a known issue with Java 1.8.0_25 and 1.8.0_31, and another known issue with Java 1.8.0_45. We don't recommend running Confluence on these versions.

最終更新日 2018 年 11 月 14 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.