Capabilities Warning Applications with flagged capabilities may be offline or older versions

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問

症状

After creating an application link from Bitbucket Server to JIRA, the warning below is shown on JIRA user interface:

Capabilities Warning Applications with flagged capabilities may be offline or older versions. Upgrade flagged applications to access more features. The table below shows application compatibility with the Development panel - older applications listed as incompatible will continue to display information in the usual locations

The following appears on JIRA UI under Project >> Administration >> Development Tools:

Expected differences between versions of JIRA 6.2.x

JIRA 6.2 will ship with the Commits tab (from the DVCS Connector) disabled. However it will ship with the Source, Reviews, and Builds tabs enabled. A later version of 6.2 (most likely 6.2.1 or 6.2.2) will add some intelligence so that these tabs are only displayed if JIRA is unable to display the associated information in the development summary panel.

原因

The problem can be caused by a few reasons:

原因 #1

If your Bitbucket Server instance is below the minimum version (2.10) required by JIRA 6.2+.

原因 #2

If the com.atlassian.plugins.atlassian-nav-links-plugin or com.atlassian.bitbucket.bitbucket-dev-summary-plugin plugins are disabled.

原因 #3

If Bitbucket Server or the other application is running behind a reverse proxy and the schemeproxyName and/or proxyPort attributes are not set correctly in the Tomcat server configuration file (conf/server.xml). The same could be happening for JIRA as well.

原因 #4

You are connecting a JIRA Cloud instance to a Bitbucket Server instance running on its standard 7990 port or non-default HTTP and HTTPS ports as expected by Cloud instances.

原因 #5

Development tools that are not configured to use 2-legged OAuth AppLinks will display a connection error to administrators on the issue.

We do not support 2-legged OAuth with impersonation (aka 2LOi).

原因 #6

You're running into a known bug,  JRA-40968 - Getting issue details... STATUS .


ソリューション

原因 #1

Please upgrade your Bitbucket Server to the latest version. Please consult Jira integration for the latest version required by Bitbucket Server and JIRA in order to see each feature.

原因 #2

Review the status of these plugins and enable them. The bug  BSERV-4698 - Getting issue details... STATUS  is known for stopping the com.atlassian.bitbucket.bitbucket-dev-summary-plugin from starting up. 

原因 #3

Add proxyName, proxyPort, and scheme attributes to the <Connector /> in the server.xml file per our Securing Bitbucket Server with Apache using SSL or Securing Bitbucket Server behind nginx using SSL docs accordingly:

<Connector port="8080"    
    ...
    scheme="https"
    proxyName="mycompany.com"
    proxyPort="443"
/>

Starting with Bitbucket Server 5.0, proxy configuration is now done in bitbucket.properties. See Proxying and securing Bitbucket Server for how to configure this.

Check this configuration is also properly done for JIRA.

Check that the base URL in Bitbucket Server or JIRA matches the proxyName attribute. Make sure that is OK.

If you made all these changes and the problem persists, please try to bypass the proxy and connect your applications directly to rule out any possibility of proxy misconfiguration.

原因 #4

If you are connecting a JIRA Cloud instance, make sure your Bitbucket Server is running on port 80 or 443 (with a valid certificate) as explained on Integrating JIRA Cloud with Bitbucket Server.

原因 #5

In JIRA, enable 2-legged authentication for the application link with the devtool:

  1. Go to the JIRA admin area and click Add-ons > Application Links
  2. Click Configure for the app link with the devtool.
  3. For both Outgoing Authentication and Incoming Authentication:
    1. Click OAuth
    2. Check Allow 2-legged OAuth.
    3. [更新] をクリックします。
  4. Go the the devtool and confirm that it has 2-legged OAuth with JIRA correctly configured.

The administrator needs to set up an applink that uses OAuth and has 2-legged OAuth allowed. This is the default for newly created applinks. If you couldn't fix your existent AppLinks as per instructions above, please delete and recreate them from scratch with the default options.

    • Trusted Applications links will not work for showing the Development Tools panel.
    • We do not support 2-legged OAuth with impersonation (aka 2LOi) for showing the Development Tools panel..

原因 #6

Follow the workarounds in  JRA-40968 - Getting issue details... STATUS .

最終更新日 2017 年 5 月 2 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.