Jira Service Management Automation Rules not working

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問


プラットフォームについて: Server と Data Center のみ - この記事は、サーバーおよびデータセンター プラットフォームのアトラシアン製品にのみ適用されます。



問題

Users complain about automation rules not working. This "symptom" can stem from various different reasons. Please check the Diagnosis section to validate if this KB is indeed applicable.

診断

  • Identify the Project(s) and the Automation rule(s) not working 
  • Go to Project Settings > Automation > Click on View log for the particular Automation Rule touted to be not working

  • Check for a record of the automation rule in the view log section. However, here there's no record of this automation rule even triggering

This is different from triggered but "NOT EXECUTED" or reporting an error. It'd appear as if nothing is recorded in the  automation logs section on the UI


  • Check if the "Run as user" user has the required permissions to trigger the automation rule. Use Permission helper to validate

原因

Service Management automation rule is not even triggered because the "Run as user" user doesn't have all the required permissions on the Project

ソリューション

  • Add the necessary permission to the "Run as user" in the project permission settings. 
  • Or Edit the rule from the options "Run as the user who triggered the rule". However, this would mean only users with required permissions on the project can trigger the automation rule.

Hint: Make sure the user has Browse Project permission on the project



説明JSM, Automation, Rule, Service Management, view log, Jira
製品
Jira, Jira, Jira Service Management



最終更新日 2020 年 11 月 25 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.