Preparing for Crowd 5.0

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問

This documentation is intended for Crowd developers who want to ensure that their existing apps are compatible with Crowd 5.0.

概要

Here you can find information about the latest EAP.

アプリケーション / 日付EAP 番号ダウンロード

Crowd

 

5.0.0-m05

(EAP1)

EAP のダウンロード

変更の概要

In this section we'll provide an overview of the changes we intend to make, so you can start thinking how it might impact your apps. Once they're ready, we'll indicate when a change has been implemented.

Removing SOAP API

Status: IMPLEMENTED

SOAP API has been deprecated in Crowd 4.3. It will no longer be available in Crowd 5.0.

If your app or custom scripts rely on using SOAP API, you’ll need to update them to use REST API instead. For information on how to migrate, see SOAP to REST migration guide.

Version upgrades

ステータス: 実装済み

Crowd 5.0 is the first Crowd version available with Platform 6 components. Here is a summary of libraries and plugins, both Atlassian-developed and third-party, which were updated as part of the Platform 6 upgrade:

変更詳細

Upgraded Atlassian Platform components and related libraries to Platform 6 compatible versions

Updated third party libraries for Platform 6.0.0 compatibility

  • commons-io → 2.9.0

  • dom4j → 2.1.3

  • guava → 31.0.1-jre

  • javax.activation → 1.2.0

  • jdom → 2.0.6.1

  • rome → 1.18.0

最終更新日 2022 年 4 月 13 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.