サポート対象プラットフォーム

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問

This page lists the supported platforms for  Bitbucket Data Center and Server 7.11.x.

See End of support announcements for upcoming changes to platforms supported by Bitbucket.

以降の情報を注意深く読み、ご自身のインスタンスに適用されるかどうかをご確認ください。 

定義

(tick) Supported - you can use Bitbucket Data Center and Server 7.11.x with this platform.

(info) Limited - you can evaluate Bitbucket on this platform, but you can't use it to run a production site. 

(warning) 非推奨 - このプラットフォームのサポートは、今後のリリースで終了する予定です。


このページの内容

ハードウェア

CPU

評価用サイト: 1 コア 
本番環境: 2 コア以上

メモリ

3 GB 以上

考慮事項

  • You'll need at least 3GB available memory. We recommend 1GB for Bitbucket and an additional 2GB to support Git operations. 
  • 個々のハードウェア要件は、Git 操作の数および頻度や、アクティブ ユーザーの数に応じて異なります。詳細については「Bitbucket Server を拡張する」をご参照ください。 

環境

(tick) Linux

(tick) Microsoft Windows (〜 500 ユーザー)

(info) Apple macOS

既知の問題

  • Microsoft Windows is not supported for Bitbucket Data Center, or for 500+ user tiers.
  • NTFS が必須であるため、Windows Resilient File System (ReFS) を使用することはできません。
  • Apple macOS は評価用にのみ使用できます。MacOS を本番環境のデプロイで使用することはできません。

考慮事項

クラウド プラットフォーム

(tick) Amazon Web Services (AWS)

(tick) Microsoft Azure

既知の問題

You can't use Amazon Elastic File System (EFS) for Bitbucket's shared home directory.

考慮事項

See  Recommendations for running Bitbucket in AWS  for more information.

Java

Oracle Java & OpenJDK

(tick) Java 11.0.8+

(warning) Java 11 through 11.0.7

(error) Java 10

(error) Java 9

(tick) Java 8 (1.8u65+ をサポート)


考慮事項

  • Bitbucket 8.0 will raise the minimum supported Java version to 11.0.8. Java versions 11.0.0 - 11.0.7 are not recommended due to Java bug: JDK-8241054

  • Bitbucket will install a supported version of AdoptOpenJDK Java JRE that is only available to Bitbucket if necessary. See Running the Bitbucket Server installer.

  • JRE を事前にインストールする場合、AdoptOpenJDK の web サイトからダウンロードできる AdoptOpenJDK の Java 8 JRE を使用することを推奨します。

  • OpenJDK については、Linux フレーバーに対応したダウンロードおよび手順の確認を http://openjdk.java.net/install/ で行えます。

  • AWS EC2 の Linux インスタンスにインストール済みの Java には、機能のサブセットが含まれている可能性があります。詳細については、「AWS EC2 インスタンスで SSH サーバーが開始に失敗する」をご参照ください

  • Oracle の公式ビルド、AdoptOpenJDK などの代替ビルド、および Red Hat Enterprise などの Linux ディストリビューションに同梱されるビルドを含む、標準の OpenJDK ビルドがサポートされます。 

データベース

PostgreSQL

(tick) 9.5 ~ 12

(warning) 9.4

MySQL  (Bitbucket Server のみ)

(tick) 8.0.11 以降

(tick) 5.7.9 以降

(tick) 5.6.16 以降

(warning) 5.5.8 以降

(tick) MariaDB 10.4.6 以降

(tick) MariaDB 10.3.7 以降

(tick) MariaDB 10.2.6 以降

(warning) MariaDB 10.1.8 以降

(error)  MariaDB 10.0.10 

(warning) MariaDB 5.5.23 以降

既知の問題

MySQL, while supported by Bitbucket, is currently not  recommended, especially for larger instances, due to inherent performance and deadlock issues that occur in this database engine under heavy load.

See Connecting Bitbucket Server to MySQL for more details and http://dev.mysql.com/doc/refman/5.0/en/innodb-deadlocks.html for some general information on deadlock issues.

You should not use Bitbucket with the following:

MySQL を Bitbucket Data Center で使用しないでください。


Microsoft SQL Server / Microsoft SQL Server Express

(tick) 2019

(tick) 2017

(tick) 2012 〜 2016



既知の問題

考慮事項

Using Windows Authentication between a Linux Bitbucket installation and SQL sever is not supported. 

Oracle

(tick) 19c

(tick) 18c

(tick) 12c

(tick) 11g



Amazon Aurora (Data Center のみ)

(tick) PostgreSQL 9.6 - 11

考慮事項

  • 唯一サポートされている Amazon Aurora 構成は、PostgreSQL 互換のクラスタ化されたデータベースで、1 つのライターが 0 個以上のリーダーにレプリケートされます。詳細情報

H2 (同梱)

(info)   Bitbucket Server、評価目的のみ

(tick)  Bitbucket ミラー


考慮事項

  • H2 is bundled with Bitbucket for evaluation use only.
  • H2 は、本番環境の Bitbucket Data Center のミラーで使用できます。

HSQLDB (同梱)

Bitbucket Server only, evaluation only
(warning) Deprecated


考慮事項

  • Please see Connect Bitbucket to an external database.
  • HSQLDB は Bitbucket Data Center ではサポートされていません。
  • HSQLDB support was deprecated as of Bitbucket 4.0+. New Bitbucket installs will bundle and use H2 as the default database for evaluation purposes.

連携

See Integrate with Atlassian applications for supported version combinations.

CI server

We recommend upgrading to the latest version of your CI server to ensure that the environment is as secure and stable as possible. See Integrated CI/CD for more information about linking Bitbucket and your CI application.


Bamboo

(tick) 5.6 – 6.10

(tick) 7.0+ (For Integrated CI/CD features)

考慮事項

Jenkins

(tick) 2.162 以降

考慮事項


ブラウザ

デスクトップ ブラウザ

(tick) Chrome (最新の安定バージョン)

(tick) Firefox (latest stable version)

(tick) MS Edge (latest stable version)

(tick) Safari (latest stable version)



考慮事項

  • Bitbucket has a minimum supported browser resolution of 1100px.
  • Bitbucket supports the latest stable version of Chromium-based Microsoft Edge and does not support legacy Microsoft Edge (versions 18 and lower).
  • Mobile browsers are not supported.

DVCS

Git – サーバー

(tick)  2.30.x 

(tick)  2.29.x 

(tick)  2.28.x 

(tick)  2.27.x 

(tick)  2.26.x 

(tick)  2.25.x 

(tick)  2.24.x 

(tick)  2.23.x 

(tick) 2.22.x

(tick) 2.21.x

(tick) 2.20.x

(tick) 2.19.x

(tick) 2.18.x

(tick) 2.17.x

(tick) 2.16.x

(tick) 2.15.x

(tick) 2.14.x

(tick) 2.13.x

(tick) 2.12.x (except 2.12.2 on Windows)*

(tick) 2.11.x


Git – サーバー

We recommend using the most recent supported version of Git on both the Bitbucket instance and clients where possible, subject to the following notes and exceptions:

  • The version of Git installed on machines that interact with Bitbucket must be compatible with the version of Git installed for use by the Bitbucket instance.

  • スマート ミラーリングを使用する場合、最小バージョンとして Git 2.11.1 がインストールされている必要があります。

  • バージョンにかかわらず、Windows サーバーにCygwin Git をインストールしないでください。

  • Git for Windows 2.12.2 には git status の不具合があり、これによってファイルの編集に失敗します。この問題は修正され、修正は Git for Windows 2.12.3 に含まれています。

  • BSERV-9673 - File editing fails using Git for Windows 2.12.2



Git – クライアント

(tick) 1.8.4.3+
(tick) 1.6.6+

Or where Git LFS is used 1.8.2

Git LFS - クライアント

(tick) 1.1.0 以降

Git – クライアント  

HTTP プロキシの動作に影響するバグが、Git バージョン 1.8.4.3 で修正されています。 

[セキュリティ脆弱性 CVE-2016-2324 & CVE-2016-2315] 複数の Git バージョンに影響します。サーバークライアント両方の Git インストールが、パッチ メンテナンス バージョンである 2.4.11、2.5.5、2.6.6、または 2.7.4 以降に更新されている必要があります。手順については、「Git のインストールとアップグレード」をご確認ください。

インターネット プロトコル


(tick) IPv4

(tick) IPv6

参考情報

When using Bitbucket in IPv6 environments, we recommend that hostnames rather than IP addresses are used .

その他のツール

Perl

(tick) 5.8.8 以降

Elasticsearch

(tick) 7.9.3

(tick) 7.5.2

(tick) 6.8.6 

(tick) 6.6.1

(tick) 6.5.3

(warning) 5.5.1 〜 5.5.3


考慮事項

  • Perl is usually provided automatically with Git.
  • Elasticsearch 6.5.3, 6.6.1, 6.8.6, 7.5.2, and 7.9.3 are supported with the Buckler plugin. Learn how to secure Elasticsearch with Buckler.
  • Elasticsearch 6.4 is supported with AWS.
最終更新日 2021 年 4 月 17 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する

このセクションの項目

Powered by Confluence and Scroll Viewport.