Bamboo 2.5 Upgrade Guide

このページの内容

サポートするプラットフォーム

We have made significant changes to our supported platforms (application servers, databases, browsers, etc) in this release. Please read the Supported platforms page for the full list of supported platforms for Bamboo.

Upgrading from Bamboo 2.4 to 2.5

We strongly recommended that you back up your xml-data directory before proceeding. For full instructions please follow the Bamboo upgrade guide.

We also strongly recommend that you export your Bamboo data for backup before proceeding. Please note, that this may take a long time to complete depending on the number of builds and tests in your system. For full instructions please see Exporting data for backup.

If you are using plugins, please make sure that your plugins are compiled against 2.5 before upgrading.

Please also note the following important points:

1. Developing for Bamboo 2.5

 
If you are a Bamboo plugin developer, please refer to our Changes for Bamboo 2.5 guide, which outlines changes in Bamboo 2.5 that may affect Bamboo plugins compiled for Bamboo version 2.4.x or earlier.

2. Remote API Support automatically enabled

 

Remote API support for your Bamboo instance will be automatically enabled when you upgrade to Bamboo 2.5. If this is a security concern, you can disable remote API support via your administration console, however Bamboo gadgets may not work correctly.

3. Database Changes

 

Please note that during the upgrade, Bamboo will automatically remove the table BUILD_ASSOCIATION and the table PLAN_DEPENDENCIES will be added. No user intervention is required. However, please ensure that Bamboo has the appropriate access to your database before the upgrade tasks are run (i.e. when you start Bamboo).

4. Pre/Post Build Command Plugin problems

 

The pre/post build command plugin (v2.4 and earlier) currently does not work with Bamboo 2.5 and will prevent you from creating new plans. If you are using this plugin, we recommend that you either disable it or wait for a new fixed version of the plugin to be released before upgrading to Bamboo 2.5.

5. "Unsupported Databases" is no longer a selectable option in Setup Wizard

 

The Setup Wizard no longer offers "Unsupported Database" as a selectable option when choosing to connect to an external database. If you are using an unsupported database, you will need to set the following system property before starting your upgraded Bamboo server to enable "Unsupported Database" as a selectable option in the Setup Wizard:
-Dbamboo.enable.unsupported.db=true

Upgrading from Bamboo prior to 2.4

In addition to the above, please read the Upgrade Guide for every version you are skipping during the upgrade. 

In particular, if you are upgrading from a version of Bamboo prior to 2.0, please ensure that you upgrade to Bamboo 2.0.6 first before upgrading to Bamboo 2.5.

Please ensure that you read the Bamboo 2.0 Upgrade Guide which contains important upgrade instructions for upgrading from earlier versions of Bamboo.

最終更新日 2014 年 9 月 17 日

この翻訳に満足しましたか?

はい
いいえ
この記事についてのフィードバックを送信する

お探しの情報が見つかりませんか?

コミュニティへの質問

Powered by Confluence and Scroll Viewport.