Unable to add Security Level field in Basic filter

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問

 

プラットフォームについて: Server、Data Center、および Cloud (状況に応じる) - この記事はアトラシアンのサーバーおよびデータセンター プラットフォーム向けに記載されていますが、Atlassian Cloud のお客様も記事の内容を利用できる可能性があります。この記事で説明されている手順の実施が役立つと考えられる場合、アトラシアン サポートにお問い合わせのうえ、この記事を紹介してください。

問題

Adding Security Level field in Basic issue filter.

原因

There is a Switching between 'Advanced' and 'Simple' Search documentation related to this issue where it stated:

  1. In general, a query created using 'Simple Search' will be able to be translated to 'Advanced Search' (i.e. JQL), and back again.
  2. However, a query created using 'Advanced Search' may not be able to be translated to 'Simple Search', where 
    In this case Security Level Field in the Issue can only queried using Advanced Search.

回避策

Security Level is not accessible from basic search in the current implementation.. A query created using 'Advanced Search' may not be able to be translated to 'Simple Search', particularly if:
the query specifies a field and value that is related to a project (e.g. version, component, custom fields) and the project is not explicitly included in the query (e.g. fixVersion = "4.0", without the AND project=JRA). This is especially tricky with custom fields since they can be configured on a Project/Issue Type basis. The general rule of thumb is that if the query cannot be created in the 'Simple Search' form and if it is created using 'Advanced Search' , then it will not be able to be translated to 'Simple Search'. 

In this case Security Level Field in the Issue can only queried using Advanced Search following this KB :

最終更新日 2018 年 11 月 2 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.