Installation Failed with 'Unable to enable web fragment' Error

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問

症状

The plugin is not able to installed successfully and the following errors appear in the logfile:

 There was an error loading the descriptor 'GreenHopper global configuration' of plugin 'com.pyxis.greenhopper.jira'. Disabling.
java.lang.RuntimeException: Unable to enable web fragment
	at com.atlassian.plugin.web.descriptors.AbstractWebFragmentModuleDescriptor.enabled(AbstractWebFragmentModuleDescriptor.java:128)
	at com.atlassian.plugin.web.descriptors.DefaultAbstractWebFragmentModuleDescriptor.enabled(DefaultAbstractWebFragmentModuleDescriptor.java:34)
	at com.atlassian.plugin.manager.DefaultPluginManager.notifyModuleEnabled(DefaultPluginManager.java:1377)
	at com.atlassian.plugin.manager.DefaultPluginManager.enableConfiguredPluginModule(DefaultPluginManager.java:1192)
	at com.atlassian.plugin.manager.DefaultPluginManager.enableConfiguredPluginModules(DefaultPluginManager.java:1155)
	at com.atlassian.plugin.manager.DefaultPluginManager.notifyPluginEnabled(DefaultPluginManager.java:1133)
...
Caused by: com.atlassian.plugin.PluginParseException: Unable to load the module's display conditions: java.lang.IllegalStateException: Cannot autowire object because the Spring context is unavailable.  Ensure your OSGi bundle contains the 'Spring-Context' header.
	at com.atlassian.plugin.web.descriptors.ConditionElementParser.makeCondition(ConditionElementParser.java:159)
	at com.atlassian.plugin.web.descriptors.ConditionElementParser.makeConditions(ConditionElementParser.java:124)
	at com.atlassian.plugin.web.descriptors.ConditionElementParser.makeConditions(ConditionElementParser.java:79)
	at com.atlassian.plugin.web.descriptors.AbstractWebFragmentModuleDescriptor.makeConditions(AbstractWebFragmentModuleDescriptor.java:67)
	at com.atlassian.plugin.web.descriptors.AbstractWebFragmentModuleDescriptor.enabled(AbstractWebFragmentModuleDescriptor.java:123)
...
(more)

During the startup, the following error might appear as well:

2010-12-24 12:23:07,610 Spring executor 3 ERROR      [extender.internal.activator.ContextLoaderListener] Application context refresh failed (NonValidatingOsgiBundleXmlApplicationContext(bundle=com.pyxis.greenhopper.jira, config=osgibundle:/META-INF/spring/*.xml))
org.springframework.beans.factory.CannotLoadBeanClassException: Error loading class [com.atlassian.greenhopper.service.issue.DefaultGHVersionService] for bean with name 'gh-versionService' defined in URL [bundle://43.0:1/com/atlassian/greenhopper/service/issue/DefaultGHVersionService.class]: problem with class file or dependent class; nested exception is java.lang.UnsupportedClassVersionError: (com/atlassian/greenhopper/service/issue/DefaultGHVersionService) bad major version at offset=6
	at org.springframework.beans
...
(more)
Caused by: java.lang.UnsupportedClassVersionError: (com/atlassian/greenhopper/service/issue/DefaultGHVersionService) bad major version at offset=6
	at java.lang.ClassLoader.defineClassImpl(Native Method)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:258)

原因

Unsupported platform such as incorrect JDK version.

ソリューション

  1. Check the System Info or from the logs for the JDK version.
  2. Try to compare the important details of the System Info (e.g. JDK version, Operating System) with the following documentation:
    1. http://confluence.atlassian.com/display/GH/Supported+Platforms
    2. http://confluence.atlassian.com/display/JIRA/Supported+Platforms

Note: This problem also related to Unable to Install JIRA Agile due to Bad Version Number in .class File

最終更新日 2021 年 8 月 10 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.