How to upgrade the embedded Jira Mobile plugin

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問

プラットフォームについて: Server と Data Center のみ - この記事は、サーバーおよびデータセンター プラットフォームのアトラシアン製品にのみ適用されます。

要約

When editing Service Management issues on the Mobile Plugin for Jira Data Center and Server, the following error is presented:
(warning)
You need an upgrade
Ask your Jira admin to upgrade Jira Service Management or the mobile plugin so you can view service projects in your app.

環境

Jira 8.13.9

Jira Service Management 4.13.9

Mobile Plugin for Jira Data Centr and Server 3.1.2 (System plugin)
.

診断


The support for Jira Service Management issues was added on the mobile plugin version 3.2.0, however, the embedded version installed with Jira is using version 3.1.2.

There is no Upgrade button available on the plugin, at the Admin > Manage Apps.

JRASERVER-72829 - 課題詳細を取得中... ステータス

ソリューション


As with all recommendations made by Atlassian Support, we suggest following best practices for change management and evaluating these settings in a test/staging environment prior to rolling out any changes to a production environment. You must test and validate these changes to ensure that they will function well within your infrastructure before considering them for production deployment.



Steps for the upgrade

  • Backup of your environment;
  • Download the plugin version from the marketplace;
  • During a maintenance window, install the mobile version:
    • Admin > "Manage Apps"
    • At the "Manage Apps" page, click on "upload app"
    • Choose the new plugin version downloaded from the marketplace.
  • After the install, the new version will be presented as a user-installed plugin, instead of a system plugin.
  • The previous jar file (jira-mobile-rest-3.1.2.jar) will remain at the <Jira Install>/atlassian-jira/WEB-INF/atlassian-bundled-plugins. We do recommend do a safety copy and remove this file to avoid conflicts.



最終更新日 2021 年 9 月 22 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.