Integration stopped working after upgrade to 2.0.7

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問

プラットフォームについて: Server および Data Center のみ。この記事は、Server および Data Center プラットフォームのアトラシアン製品にのみ適用されます。

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Fisheye および Crucible は除く

問題

Some unsupported integrations may stop working after the upgrade of Hipchat Server to 2.0.7. 

At this point, we did not get any reports of this issue impacting integrations available on marketplace.atlassian.com

The integrations we know were impacted are: 

No errors will be logged on the Hipchat Server side. Some SSL related errors will be logged on the third-party side. Plugin crashes might also be observed if the exception is not handled properly. For example:

[ERROR] HipChat notification failed with error message: Unexpected IO error occurred while sending notification: javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure


原因

TLS 1.0 fallback support has been removed from Hipchat Server 2.0.7. If the integration has it enabled and the use of a newer TLS version fails for some reason, the integration will either throw an exception or crash. 

ソリューション

The solution to this issue is to disable TLS 1.0 fallback for outbound connections in the integration code. For example, How do I disable SSL fallback and use only TLS for outbound connections in .NET?

 

最終更新日 2018 年 11 月 2 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.