Confluence 2.9 アップグレード ノート

このページの内容

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問

Below are some essential notes on upgrading to Confluence 2.9. For details of the new features and improvements in this release, please read the Confluence 2.9 Release Notes.

このページの内容

アップグレード ノート

プラグイン

Please check the following if you have added any plugins to Confluence:

  • サードパーティ プラグインを使用している場合は、2.9 を本番環境で導入する前に徹底的にテストしてください。
  • If you have installed the Gallery plugin onto your Confluence site, please remove it (or do not reinstall it after upgrading Confluence) in order to get the benefit of the new Gallery macro. The Gallery macro has been significantly improved in this release. It now incorporates features which were previously available only in the separate Gallery plugin.
  • ページツリー プラグインまたはページツリー検索プラグインを Confluence サイトにインストールした場合は、新しいページツリー マクロのメリットが得られるように、それらを削除してください (または Confluence のアップグレード後に再インストールしないでください)。このリリースでは、ページツリー マクロが大幅に改善されました。以前のページツリー プラグインを置き換えて、ページツリー検索オプションを組み込んでいます。
  • ブログ投稿マクロを使用している場合は、無効なスペース キーが検出されてマクロが失敗する原因になることにご注意ください。以前は無視されていて、すべてのスペースのブログ投稿が返されていました。

Java Versions

Java 1.4 is not supported in Confluence 2.9 and later. Please refer to the Java 1.4 Support Timeline for more information.

Before upgrading to Confluence 2.9, you will need to ensure your environment is running at least Java 5. Confluence 2.9 supports Java 5 and Java 6. We recommend Java 6 because of its increased performance and easier troubleshooting, due to enhanced memory dump and profiling capabilities.

You can check your current Java version in Confluence:

  1. 設定アイコン を選択し、[一般設定] を選択します。
  2. Select 'System Information' from the 'Administration' section in the left-hand panel.
  3. Refer to 'Java Version'.
    • If the version is 1.5 or higher, you do not need to do anything.
    • バージョンが 1.4 の場合は、Confluence 2.9 にアップグレードする前に JDK をアップグレードする必要があります。

独自のアプリケーション サーバーに対して Confluence EAR-WAR エディションを実行している場合は、サポートされている JDK のバージョンについてアプリケーション サーバーのベンダーに確認する必要があります。

サポートされているデータベースとアプリケーション サーバー

Additions to Application Server Support

公式にサポートされているアプリケーション サーバーのリストに、次のバージョンを追加しました。

  • Resin 3.0 and 3.1
  • Tomcat 6 (認証済みデータソースに関する既知の問題を参照)
Platforms No Longer Supported

次のプラットフォームは Confluence 2.8 の「サポートされていないが動作する」リストに含まれていました。これらは Confluence 2.9 の時点でそのリストには載っていません。おそらくまだ動作しますがテストはしていないため、すぐにアップグレードしてください。

  • MySQL 4.0 — please upgrade to MySQL 5
  • SQLServer 2000 — SQLServer 2005 にアップグレードしてください
  • Websphere 6.0 — Websphere 6.1 にアップグレードしてください
  • WebLogic 8.1 — Weblogic 9.2 にアップグレードしてください。

最新のマトリックスについては、「サポートされているプラットフォーム」トピックにあるサポートされているアプリケーション サーバーとデータベースのリストをご参照ください。

事前告知 — 次のリリースでサポートされているプラットフォームの変更

The next major release of Confluence after 2.9 will not support the following platforms/versions any more. We will still test those platforms infrequently, and Confluence will probably still work fine with them for a while, but they will be not officially supported.

  • MySQL 4.1 — please upgrade to MySQL 5
  • Tomcat 5.0 — please upgrade to Tomcat 5.5 or 6
  • Resin 2 — please upgrade to Resin 3
  • JBoss 4.0.x — please upgrade to JBoss 4.2.x

JavaScript Libraries

jQuery は、プラグイン開発者向けのサポート対象 JavaScript ライブラリです。

Advance notice — deprecated libraries: We have decided to standardize on jQuery as the JavaScript library for Confluence. This library will eventually replace all others. For this reason, use of the following JavaScript libraries in Confluence is deprecated:

Because there is a lot of legacy plugin code using Prototype and Scriptaculous, these will continue to be available for this release of Confluence.

Yahoo! ユーザー インターフェイス ライブラリ (YUI) は、Confluence 2.8 における廃止に伴い、このリリースから削除されました

Confluence Themes

事前通知 — Confluence クラシック テーマは今後のリリースで廃止される予定です。Confluence 2.9 は、Confluence クラシック テーマをサポートする最後のバージョンになります。このテーマが使用する古いタイポグラフィーと書式設定は、Confluence 2.6 で新しい外観の既定のテーマに置き換えられました。クラシック テーマは、当時古いタイポグラフィーを使用されていたお客様への影響を最小限に抑えるために導入されました。Confluence 2.9 以降、クラシック テーマはサポートされなくなります。

アップグレード手順

Upgrade a test environment first

アップグレードは、本番環境に適用する前にテスト環境で必ずテストしてください。

すでに Confluence のいずれかのバージョンを実行している場合、以下の手順に従って最新バージョンにアップグレードしてください。

  1. Before you upgrade, we strongly recommend that you back up your Confluence home directory and database. See the documentation on backing up your Confluence site. If you are using an external database, perform a database backup.
  2. ご使用の Confluence のバージョンが 2.8.x より前の場合、そのバージョンから最新バージョンまでのすべてのリリースのリリース ノートおよびアップグレード ガイドを読んでください。特に、次のものが見受けられる。
    • 2.8 アップグレード ノートをお読みください。
    • 2.1 以前のバージョンからアップグレードする際には、2.2 リリース ノートをお読みください。
    • If you are upgrading from 2.2 or earlier, you will need to upgrade to Confluence 2.7.0 first, confirm the upgrade was successful, then upgrade again from version 2.7.0 to version 2.8.2. For more details, please refer to CONF-11767.
  3. Download the latest version of Confluence.
  4. Follow the instructions in the Upgrade Guide.
  5. If you encounter a problem during the upgrade, please create a support ticket and one of our support engineers will assist you through the process.
関連トピック

Confluence 2.9 リリース ノート

最終更新日 2016 年 8 月 10 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.