Unable to Install Confluence or Load Plugins on Websphere 6.1


アトラシアン コミュニティをご利用ください。


[Unable to render {include} The included page could not be found. ({include} をレンダリングできません。ページが見つかりませんでした)] を選択し、


Two symptoms can occur from classloader problems:

  • Confluence cannot start
  • Some plugins (eg. plugin repository client) are disabled with no way of enabling it.

The following error appears in the SystemOut.log file:

2009-02-04 12:31:43,849 ERROR [WebContainer : 1] [plugin.event.impl.DefaultPluginEventManager] notify Exception calling listener method -- referer: http://localhost:9080/confluence_test/setup/setuplicense.action | url: /confluence_test/setup/setupembeddeddb-default.action | userName: anonymous | action: setupembeddeddb-default com.atlassian.plugin.osgi.container.OsgiContainerException: Detected older version (4.0 or earlier) of OSGi. If using WebSphere 6.1, please enable application-first (parent-last) classloading and the 'Single classloader for application' WAR classloader policy.


WebSphere 6.1 has several issues with running applications that use the plugin framework. First, it itself is built on OSGi, however, an older version of the specification, 4.0, whereas the plugin framework expects 4.1. Also, the WebSphere classloader doesn't support classloader scanning, a technique used by the plugin framework to discover which packages are available from the host application automatically. Specifically, the classloader doesn't return results when looking for packages or directories, which is necessary for most scanning techniques.


Last modified on Mar 30, 2016


Powered by Confluence and Scroll Viewport.