"Manage Apps" or "Manage add-ons" menu does not populate after upgrading the Universal Plugin Manager

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問


プラットフォームについて: サーバーと Data Center のみ。この記事は、サーバーおよび Data Center プラットフォームのアトラシアン製品にのみ適用されます。

問題

After updating Confluence UPM the Manage apps (or Manage add-ons in older versions) page displays, but no add-ons are listed and the filters do not work correctly. There are no errors in the atlassian-confluence.log and the only error present is a Javascript error on the browser: 

com.atlassian.upm.atlassian-universal-plugin-manager-plugin:upm-requirejs.js:3045 Uncaught SyntaxError: Unexpected token ILLEGAL
l.template	@	com.atlassian.upm.atlassian-universal-plugin-manager-plugin:upm-requirejs.js:3045
(anonymous function)	@	com.atlassian.upm.atlassian-universal-plugin-manager-plugin:upm-manage-templates.js?locale=XX-XX:1342

原因

There is an add-on that is not compatible with the new version of the UPM.

回避策

The workaround is to install a previous version of UPM, enable 'Safe Mode' prior to upgrading, and then upgrade to avoid add-on compatibility issues.

  1. Confluence をシャットダウンします。
  2. Confluence を実行しているユーザーに confluence-home ディレクトリへの完全な読み取り / 書き込み権限が割り当てられていることを確認します。
  3. Remove the following directories

    tip/resting Created with Sketch.

    This will remove the plugin cache files only and will not permanently remove any plugins. These directories will be recreated during the next Confluence startup.  However, some third-party plugins may store metadata in these directories, so we recommend creating a temporary backup of the directories.

    • <confluence-home>/bundled-plugins
    • <confluence-home>/plugins-cache
    • <confluence-home>/plugins-osgi-cache
    • <confluence-home>/plugins-temp
    • <confluence-home>/bundled-plugins_language
  4. Generate a backup for your database.
  5. Delete the pluginkey from the database. For the UPM, the sql statement would resemble:

    delete from plugindata where pluginkey like 'com.atlassian.upm.atlassian-universal-plugin%';

    This will remove 1 OR 2 plugins. Both are safe to delete from the database. Also, this is the syntax for postgreSQL and may have to be modified to work on your specific database setup.

  6. Confluence を起動します。
  7. If the default version of UPM is not found in the Manage Add-Ons page, Manually install the UPM that is a previous version than the one you updated to. The versions and downloads can be found here.
  8. Once confirmed working, put the UPM into Safe Mode.
  9. Exit Safe Mode, but but ensure to click the option "Exit safe mode but do not restore the previous configuration", which should allow all your other user-installed plugins to remain disabled.
  10. Upgrade the UPM to the version that caused the issue.
  11. Enable the third party add-ons one by one.

ソリューション

The resolution is to find the add-on causing the Javascript error in the first place and disable it.

  1. Navigate to the Manage Add-Ons page.
  2. Enable the Google Javascript Console.
  3. Reload the page and see if there are any errors such as 'Unexpected token ILLEGAL'.
  4. Expand the error details in the console.

  5. See if there are any errors such as:

    com.atlassian.upm.atlassian-universal-plugin-manager-plugin:upm-requirejs.js:3045
    (anonymous function)	@	com.atlassian.upm.atlassian-universal-plugin-manager-plugin:upm-manage-templates.js?locale=xx-xx 1342
  6. Note the language after locale. For example, locale=en-US.
  7. Go to the Manage Add-Ons page and disable the language add-on displayed in step 6. In this example the add-on is Confluence English (United States) Language Pack.


最終更新日 2019 年 5 月 3 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.