How to migrate from JIRA Issues and JIRA portlets to gadgets

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問

目的

Gadgets replaced portlets in JIRA 4.0 and Confluence 3.1. We deprecated the use of JIRA portlets in Confluence 4.2 (see the Confluence 4.2 upgrade notes) and have removed the portlet code in Confluence 4.3.

In Confluence 4.3 and later, the JIRA Portlet macro is no longer supported. Pages that contain the JIRA Portlet macro will no longer display information drawn from JIRA. Instead, they will show an error reporting that the macro does not exist. To prevent this behavior, please upgrade to a version of JIRA that supports gadgets, and follow the instructions on this page to change your JIRA portlet macros to gadgets.

Note that the JIRA Issues macro continues to be supported in Confluence. In some cases, you may also choose to use a gadget instead of the JIRA Issues macro.

Because of the wide variety of differences in invocations, it is a manual process to exchange your macros for gadgets.

ソリューション

You will need to remove the JIRA Portlet macro and add the corresponding gadget:

  1. Add either trusted communication or OAuth between your JIRA and Confluence sites. See Linking to Another Application and Configuring authentication for an application link.
  2. Register the JIRA Portlet gadget, and any other gadgets that you want, as external gadgets on your Confluence site. See Registering External Gadgets. (See All Atlassian Gadgets for a list of available gadgets.)
  3. Edit all your Confluence pages that contain JIRA Portlet macros, replacing the JIRA Portlet macros with gadget macros.

 

最終更新日: 2016 年 2 月 23 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.