How to disable SSLv3 to mitigate against POODLE exploit for Confluence 5.7.0 or below

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問

目的

If you have enabled the SSL connector for Confluence using <confluence_install>/conf/server.xml, the default settings do not block SSLv3 connections which can be exploited by the POODLE fallback attack. There are two changes that need to be made to the SSL connector. By default, the SSL connector sets sslProtocol="TLS" which starts both TLS connectors and SSLv3 connectors. You can tell if you are affected by opening <confluence_install>/conf/server.xml and find the SSL connector, example follows:

<Connector port="8443" maxHttpHeaderSize="8192"
           maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
           enableLookups="false" disableUploadTimeout="true"
           acceptCount="100" scheme="https" secure="true"
           clientAuth="false" sslProtocol="TLS" SSLEnabled="true"
           URIEncoding="UTF-8" keystorePass="<MY_CERTIFICATE_PASSWORD>"/>

また、お気付きかもしれませんが、Google Chrome などの一部の Web ブラウザーでは、ご使用の SSL が有効なインスタンスへのブラウズに失敗し、次のようなエラーメッセージが表示されます。

A secure connection cannot be established because this site uses an unsupported protocol

回避策

  • Edit the SSL connector in server.xml as follows:

    <Connector port="8443" maxHttpHeaderSize="8192"
               maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
               enableLookups="false" disableUploadTimeout="true"
               acceptCount="100" scheme="https" secure="true"
               clientAuth="false" sslProtocol="TLS" sslEnabledProtocols="TLSv1.2,TLSv1.1,TLSv1" SSLEnabled="true"
               URIEncoding="UTF-8" keystorePass="<MY_CERTIFICATE_PASSWORD>"/>
  • In older versions of Tomcat (up to 6.0.32) the property sslEnabledProtocols didn't exist. If you're running Confluence 4.0.X or older, please edit the SSL connector as follows instead:

    <Connector port="8443" maxHttpHeaderSize="8192"
               maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
               enableLookups="false" disableUploadTimeout="true"
               acceptCount="100" scheme="https" secure="true"
               clientAuth="false" sslProtocols="TLSv1,TLSv1.1,TLSv1.2" SSLEnabled="true"
               URIEncoding="UTF-8" keystorePass="<MY_CERTIFICATE_PASSWORD>"/>
  • At this point, you can start Confluence and use something like SSLScan to verify that connections can only be made through TLS and not SSLv3.


ソリューション

  • Install Confluence 5.7.1 or higher as it includes a bundled Tomcat that is not affected by POODLE
  • CONF-35386 - 課題詳細を取得中... ステータス
最終更新日 2016 年 6 月 14 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.