Error When Uploading Global Logo

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問

症状

When inserting a global logo, an error is reported when clicking save. 

There were errors uploading this logo. There is more information in the logs.

atlassian-confluence.log に次のメッセージが表示される。

ERROR [http-80-9] [confluence.plugins.lookandfeel.EditSiteLogoAction] doUpload There were errors uploading this logo. There is more information in the logs.
 -- referer: http://localhost/admin/sitelogo/upload.action | url: /admin/sitelogo/upload.action | userName: admin | action: upload
java.lang.RuntimeException: Error opening input stream from resource: UploadedResource[filename: 'atl.site.logo', file: '\Atlassian\Application Data\Confluence\temp\scaledImages\upload__6d5c001a_13f3c86e042__7f65_00000033.tmp']
	at com.atlassian.confluence.pages.DefaultFileUploadManager.storeResources(DefaultFileUploadManager.java:146)
	at com.atlassian.confluence.pages.DefaultFileUploadManager.storeResource(DefaultFileUploadManager.java:64)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)...
Caused by: java.io.FileNotFoundException: Atlassian\Application Data\Confluence\temp\scaledImages\upload__6d5c001a_13f3c86e042__7f65_00000033.tmp (The system cannot find the file specified)
	at java.io.FileInputStream.open(Native Method)
	at java.io.FileInputStream.<init>(Unknown Source)
 
ERROR [http-80-6] [atlassian.confluence.pages.DefaultAttachmentManager] getAttachmentData Could not find data for attachment: Attachment: atl.site.logo v.1 (1867780) null - No AttachmentData object was returned when it was expected for attachment: Attachment: atl.site.logo v.1 (1867780) null
 -- referer: http://localhost/admin/sitelogo/upload.action | url: /s/en_GB-1988229788/4108/b47156ace146e4f759b49ef98258cb637bdd5af8.23/_/images/logo/confluence-logo.png | userName: admin
 
ERROR [http-80-6] [[Standalone].[localhost].[/].[default]] log Servlet.service() for servlet default threw exception
 -- referer: http://localhost/admin/sitelogo/upload.action | url: /s/en_GB-1988229788/4108/b47156ace146e4f759b49ef98258cb637bdd5af8.23/_/images/logo/confluence-logo.png | userName: admin
java.lang.NullPointerException
	at com.atlassian.plugin.servlet.util.LastModifiedHandler.calculateLastModifiedDate(LastModifiedHandler.java:54)
	at com.atlassian.plugin.servlet.util.LastModifiedHandler.checkRequest(LastModifiedHandler.java:71)

原因

This might be related to CONF-21439 - Getting issue details... STATUS  

ソリューション

  1. Reset the global logo to default
  2. Connect to the database
  3. 次のクエリを実行します。
    • For Confluence 5.6.6 and below

      delete from attachments where title = 'alt.site.logo';
    • For Confluence 5.7 and above

      delete from content where title = 'alt.site.logo';
  4. Attempt to upload the global logo again from the UI.

(info) You might note in newer versions that the auto theme coloring does not take when you alter the logo this time. This is most likely due to a flag in the database not being reset.

 

 

最終更新日 2018 年 11 月 2 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.