SSL および Apache 2.4.9 以前のバージョンを使用すると Confluence 共同編集機能を使用できません。

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問

アトラシアンのアプリケーションはリバースプロキシの使用を許可します。しかし、アトラシアンのサポートはその設定に対してサポートの提供は行いません。つまり、アトラシアン はリバースプロキシに対するあらゆるサポートの提供を保証できません

設定に関してサポートが必要であれば、Atlassian Answers に質問をあげてください。


この記事はアトラシアンのサーバー製品にのみ適用されます。クラウドとサーバー製品の違いについてはこちらをご確認ください。

問題

Confluence 6.x is configured with Apache 2.4 using SSL and Websockets as described in this guide: Securing your Atlassian applications with Apache using SSL

However, when trying to use collaborative editing, you get an error in the browser and the editor does not load. 

診断

環境

  • Confluence 6 or higher
  • Apache 2.4.9 or earlier (Not Apache 2.2, as it does not support Websockets at all)
    • If you are on Apache 2.2, please upgrade to the latest version of 2.4 and check if the issue persists
  • SSL configured in Apache and/or Tomcat level
  • The appropriate modules are loaded, specifically mod_proxy_wstunnel.so

診断ステップ

原因

The following bug breaks the SSL handshake because it sends plain-text requests to the Websockets URL, as opposed to SSL requests:  Plain-text request is sent to WSS URL (which should be over SSL) in mod_proxy_wstunnel

回避策

Workarounds are ways to temporally circumvent a problem, although it still exists in the application.

ソリューション

Upgrade to Apache 2.4.10 or higher. For some operating systems there is a fix available that has been tested using Apache version 2.4.6-45.

説明

Confluence 6+ is configured with Apache 2.4 using SSL and Websockets as described in this guide: FIZME Securing your Atlassian applications with Apache using SSL

However, when trying to use collaborative editing, you get an error in the browser and the editor does not load. 

製品 Confluence
プラットフォーム サーバー
最終更新日: 2018 年 9 月 10 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.