Cannot update add-ons on the Manage Apps page

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問


プラットフォームについて: サーバーと Data Center のみ。この記事は、サーバーおよび Data Center プラットフォームのアトラシアン製品にのみ適用されます。

要約

When updating the add-ons through the "Manage Apps" page, an error is thrown on the UI with the following message:

An error occurred during installation. Refer to the logs for more information


診断


  • The following NullPointerException error is found in the logs:
2020-04-02 15:22:08,105 WARN [http-nio-8090-exec-10] [atlassian.upm.pac.PacClientImpl] getUpdates The request to check for app updates may take longer than expected because xx apps are installed that could have updates. This may impact the performance of loading the Manage Apps page.
 -- referer: http://localhost:8090/plugins/servlet/upm | url: /rest/plugins/1.0/installed-marketplace | traceId: 6bc592c38597a483 | userName: admin-chard
2020-04-02 15:22:42,945 WARN [UpmAsynchronousTaskManager:thread-1] [atlassian.confluence.plugin.DatabasePluginScanner] loadNewPluginsFromDatabase Exception when loading plugins from the database
 -- url: /rest/plugins/1.0/ | referer: http://localhost:8090/plugins/servlet/upm | traceId: 561bacc3fcc3e973 | userName: admin
java.lang.NullPointerException
	at com.google.common.base.Preconditions.checkNotNull(Preconditions.java:877)
	at com.google.common.io.ByteStreams.copy(ByteStreams.java:104)
	at com.atlassian.confluence.plugin.DatabasePluginScanner.writePluginData(DatabasePluginScanner.java:150)
	at com.atlassian.confluence.plugin.DatabasePluginScanner.lambda$null$0(DatabasePluginScanner.java:174)
  • Clearing the plugins cache does not resolve the issue.

原因

One of the installed plug-ins appears to be corrupt and is blocking UPM

ソリューション

最終更新日: 2021 年 1 月 14 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.