サポート対象プラットフォーム

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問

このページでは、Confluence を実行するために必要な追加のソフトウェアおよびインフラストラクチャについて説明します。Confluence をインストールする前にこの情報を確認してください。このページの情報は、Confluence Server および Data Center 7.5 に対応しています。

  • Confluence はサポート対象のプラットフォームでのみ使用してください。このページに記載されていないプラットフォームとバージョンについては、テストやバグの修正を行っておらず、サポートも適用されません。 
  • サポート対象プラットフォームの今後の変更については、Confluence のサポート終了のお知らせを参照してください。
  •  > [一般設定] > [トラブルシューティングとサポート ツール] に移動し、インスタンスの健康状態を確認します。ライセンスの有効性、Tomcat のバージョン、基本データベース設定などを確認することができます。 

定義

(tick) サポート対象 - このプラットフォームで Confluence Server および Data Center 7.5 を使用できます。

(info) 制限付き - このプラットフォームで Confluence を評価できますが、本番 Confluence サイトの稼働には使用できません。 

(warning) 非推奨 - このプラットフォームのサポートは、今後のリリースで終了する予定です。

ブラウザ

デスクトップ ブラウザ

(tick) Microsoft Edge

(tick) Chrome

(tick) Firefox

(tick) Safari (Mac のみ)

モバイル ブラウザ

(tick) Chrome

(tick) Firefox

(tick) Safari (iOS のみ)

(tick) Android 4.4 (KitKat) 以降

モバイル オペレーティング システム
(モバイル アプリに必要)

(tick) iOS 11 以降

(tick) Android 4.4 (KitKat) 以降

参考情報

  • Confluence セットアップ ウィザードには、Confluence のインストール中に有効にされる Javascript が必要です。詳細
  • ブラウザのウィンドウ サイズが 1024x768 未満の場合、Confluence の一部が正しく表示されません。

オペレーティング システム

オペレーティング システム

(tick) Microsoft Windows

(tick) Linux (ほとんどのディストリビューション)

(info) MacOS/OS X (評価用のみ)


既知の問題

  • 次のオペレーティング システムの派生版では Confluence を使用できません。
    • Windows Nano
    • Alpine Linux (3.5 以前)

参考情報

  • Confluence は 32 ビットまたは 64 ビットのオペレーティング システムで実行できますが、インストーラーは 64 ビット オペレーティング システム用のみ提供されています。 
  • MacOS/OSX で Confluence を評価することはできますが、Mac での本番 Confluence サイトのインストールおよび実行はできません。 

データベース

PostgreSQL

(tick) PostgreSQL 9.6

(tick) PostgreSQL 10

Amazon Aurora 
(Data Center のみ)

(tick) PostgreSQL 9.6

MySQL

(tick) MySQL 5.7

(tick) MySQL 8 

Oracle

(tick) Oracle 12c Release 2

(tick) Oracle 19c

Microsoft SQL Server

(tick) SQL Server 2016

(tick) SQL Server 2017

(tick) Azure SQL

組み込みデータベース

(info) H2 (評価専用)

既知の問題

  • Confluence は、以下のような MySQL 派生版では使用できません。
  • Confluence は、Oracle のネイティブ ネットワーク暗号化に応答しなくなる場合があります。CONFSERVER-60152 で移行オプションをご確認ください。

参考情報

  • 組み込み H2 データベースは評価専用です。本番サイトでは、このページにリストされているサポート対象の外部データベースのいずれかを使用する必要があります。 
  • このページに記載されているサポート対象のデータベースには、Amazon のリレーショナル データベース サービス (RDS) を使用できます。
  • 唯一サポートされている Amazon Aurora 構成は、PostgreSQL 互換のクラスタ化されたデータベースで、1 つのライターが 0 個以上のリーダーにレプリケートされます。詳細情報

Java

Oracle JRE / JDK

(tick) Java 1.8

(tick) Java 11

AdoptOpenJDK

(tick) Java 8 (HotSpot)

(tick) Java 11 (HotSpot)

既知の問題

  • 一部の Oracle Java バージョンには Confluence に影響するバグが存在します。Java 1.8.0_25 および 1.8.0_31 (JDK-8059299 を参照) または Java 1.8.0_45 (JDK-8068400 参照) では Confluence を実行できません。
  • 一部の AdoptOpenJDK バージョンには Confluence に影響するバグが存在します。バージョン jdk8u202 (CONFSERVER-58784 を参照) をおすすめします。
  • AdoptOpenJDK の OPENJ9 JVM で Confluence を実行することはできません。HotSpot JVM をご利用ください。 
  • アトラシアンでは、OpenJDK に関連して提起された課題を AdoptOpenJDK を使用して再現しています。OpenJDK の別のディストリビューションを使用している場合でも、製品のサポートは提供されますが、Java ディストリビューションの問題によって不具合が発生している場合は、Java ディストリビューターにお問い合わせいただく必要があります。

参考情報

  • インストーラーを使用してConfluence をインストールする場合、Confluence に (AdoptOpenJDK が提供する) Java 11 JRE がバンドルされているため、Java のインストールは不要です。
  • バンドル済みの Tomcat および Java のバージョン」を参照して、ご使用の Confluence バージョンにバンドルされていた Java のバージョンを確認します。 

インフラストラクチャ

ハードウェア

  • SPARC ベースのハードウェア上で Confluence を実行することはできません。x86 ハードウェアまたは 64 ビット版 x86 ハードウェアを使用する必要があります。
  • ライセンス要件により、NFS マウントはインストール ディレクトリまたはホーム ディレクトリには使用できません。Confluence Data Center をインストールする場合、共有ホーム ディレクトリでは NFS マウントに問題なくても、ローカル ホーム ディレクトリでは問題が発生する場合があります。

仮想化

  • 仮想環境 (Docker を含む) で Confluence および Confluence Data Center を実行することはできますが、サポート チームは環境自体に関する問題の支援は行うことができません。「仮想環境における Confluence の実行」を参照してください。  
  • アトラシアンのサポート チームが、Cloud Formation Template または Quick Start を使用した AWS での Confluence Data Center のデプロイを支援します。Cloud Formation Template が大幅にカスタマイズされている場合、サポート対象外となります。 

アプリケーション サーバー

  • ご使用の Confluence バージョンにバンドルされている Tomcat バージョンのみがサポート対象です。独自のアプリケーション サーバーで Confluence を実行することはできません。「バンドル済みの Tomcat および Javaのバージョン」を参照して、お使いの Confluence のバージョンにバンドルされていた Tomcat のバージョンを確認します。 

インターネット プロトコル

  • Confluence は IPv4 および IPv6 環境の両方で実行できます。
  • IPv6 の元のアドレスは常に認識されるわけではありません。制限や既知の問題については、Confluence 6.9 アップグレード ノートを参照してください。 

オペレーティング システムのサポート

  • アクティブなベンダー サポートがあるオペレーティング システム バージョンでのみ Confluence をインストールおよび使用する必要があります。たとえば、別途指定されている場合を除き、Microsoft によってサポートされているすべての Windows バージョンで Confluence を使用できます。 

詳細は、「サーバーのハードウェア要件ガイド」と「システム要件」を参照してください。 

最終更新日 2020 年 11 月 2 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.