Could not login admin user after admin account creation at setup

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問

プラットフォームについて: Server と Data Center のみ - この記事は、サーバーおよびデータセンター プラットフォームのアトラシアン製品にのみ適用されます。

問題

The following error appears on the screen after creating the admin account in the setup process:

java.lang.SecurityException: Could not login admin user '<userName>'

The following appears in the atlassian-bamboo.log

2015-05-11 12:20:15,170 INFO [http-bio-8085-exec-6] [AccessLogFilter] <requestIP> GET http://<instanceURL>/setup/setupAdminUser.action 158536kb
2015-05-11 12:26:03,285 INFO [http-bio-8085-exec-13] [AccessLogFilter] <requestIP> POST http://<instanceURL>/setup/performSetupAdminUser.action 124708kb
2015-05-11 12:26:04,015 INFO [http-bio-8085-exec-13] [DefaultAuthenticator] login : '<userName>' could not be authenticated with the given password
2015-05-11 12:26:04,015 WARN [http-bio-8085-exec-13] [DefaultAuthenticator] login : '<userName>' tried to login but they do not have USE permission or weren't found. Deleting remember me cookie.
2015-05-11 12:26:04,017 ERROR [http-bio-8085-exec-13] [ExceptionMappingInterceptor] Could not login admin user '<userName>'
java.lang.SecurityException: Could not login admin user '<userName>'
	at com.atlassian.bamboo.ww2.actions.setup.SetupAdminUserAction.loginAdminAccount(SetupAdminUserAction.java:68)
	at com.atlassian.bamboo.ww2.actions.setup.SetupAdminUserAction.execute(SetupAdminUserAction.java:44)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:497)
	at com.opensymphony.xwork2.DefaultActionInvocation.invokeAction(DefaultActionInvocation.java:450)
	at com.opensymphony.xwork2.DefaultActionInvocation.invokeActionOnly(DefaultActionInvocation.java:289)
	at com.opensymphony.xwork2.DefaultActionInvocation.invoke(DefaultActionInvocation.java:252)
	at com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor.doIntercept(DefaultWorkflowInterceptor.java:168)
	at com.atlassian.bamboo.ww2.interceptors.BambooWorkflowInterceptor.validateWorkflow(BambooWorkflowInterceptor.java:54)
	at com.atlassian.bamboo.ww2.interceptors.BambooWorkflowInterceptor.access$000(BambooWorkflowInterceptor.java:16)
	at com.atlassian.bamboo.ww2.interceptors.BambooWorkflowInterceptor$1.call(BambooWorkflowInterceptor.java:33)
	at com.atlassian.bamboo.ww2.interceptors.BambooWorkflowInterceptor$1.call(BambooWorkflowInterceptor.java:29)
	at com.atlassian.bamboo.util.BambooProfilingUtils.withUtilTimerStack(BambooProfilingUtils.java:51)
	at com.atlassian.bamboo.ww2.interceptors.BambooWorkflowInterceptor.doIntercept(BambooWorkflowInterceptor.java:28)
	at com.opensymphony.xwork2.interceptor.MethodFilterInterceptor.intercept(MethodFilterInterceptor.java:98)
	at com.opensymphony.xwork2.DefaultActionInvocation.invoke(DefaultActionInvocation.java:246)

原因

Bamboo is using the wrong authenticator to authenticate the newly created administrator account. Example scenario:

  • The installation directory is copied from an existing instance which is already configured to use SSO.

ソリューション

  1. Ensure that the Crowd SSO authenticator is commented in Bamboo Installation/atlassian-bamboo/WEB-INF/classes/seraph-config.xml is commented

        <!-- <authenticator class="com.atlassian.crowd.integration.seraph.v25.BambooAuthenticator"/> -->
  2. Ensure that the Bamboo authenticator is commented in Bamboo Installation/atlassian-bamboo/WEB-INF/classes/seraph-config.xml is not commented

        <authenticator class="com.atlassian.bamboo.user.authentication.BambooAuthenticator"/>


  3. Restart Bamboo

 

Last modified on Mar 30, 2016

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.