Build 2.7.4 from source fails - Failed to resolve artifact

お困りですか?

アトラシアン コミュニティをご利用ください。

コミュニティに質問

症状

Having downloaded the Bamboo 2.7.4 source code from https://my.atlassian.com and trying to build it (using either build.bat or build.sh) the build fails with the following error:

[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Failed to resolve artifact.
Missing:
----------
1) com.atlassian.bamboo:atlassian-bamboo-agent-elastic-image-default:ami:2.7.4
  Try downloading the file manually from the project website.
  Then, install it using the command:
      mvn install:install-file -DgroupId=com.atlassian.bamboo -DartifactId=atlassian-bamboo-agent-elastic-image-default -Dversion=2.7.4 -Dpackaging=ami -Dfile=/path/to/file
  Alternatively, if you host your own repository you can deploy the file there:
      mvn deploy:deploy-file -DgroupId=com.atlassian.bamboo -DartifactId=atlassian-bamboo-agent-elastic-image-default -Dversion=2.7.4 -Dpackaging=ami-Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
  Path to dependency:
        1) com.atlassian.bamboo:atlassian-bamboo-agent-elastic-server:jar:2.7.4
        2) com.atlassian.bamboo:atlassian-bamboo-agent-elastic-image-default:ami:2.7.4
----------
1 required artifact is missing.
for artifact:
  com.atlassian.bamboo:atlassian-bamboo-agent-elastic-server:jar:2.7.4
from the specified remote repositories:
  central (https://m2proxy.atlassian.com/repository/internal),
  atlassian-m1-repository (https://maven.atlassian.com/repository/m1/),
  atlassian-proxy (https://m2proxy.atlassian.com/repository/public)
[INFO] ------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 5 minutes 7 seconds
[INFO] Finished at: Fri Jun 22 17:59:35 BRT 2012
[INFO] Final Memory: 108M/247M
[INFO] ------------------------------------------------------------------------

原因

Some artifacts are missing in the Maven repository. This bug report was raised in order to track this problem:  BAM-11752 - Getting issue details... STATUS

It looks like this problem happens only in version 2.7.4.

ソリューション

Depending on what you want the source for, you could just try to use the 2.7.3 version instead. From 2.7.3 to 2.7.4 there were only a few minor fixes, so the code would be quite similar.

 

最終更新日 2016 年 11 月 29 日

この内容はお役に立ちましたか?

はい
いいえ
この記事についてのフィードバックを送信する
Powered by Confluence and Scroll Viewport.